summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJukka Rissanen <jukka.rissanen@linux.intel.com>2012-11-12 14:07:58 +0200
committerPatrik Flykt <patrik.flykt@linux.intel.com>2012-11-23 12:58:52 +0200
commitacedf9d49b9a326771aeec755179e3ede3872cdd (patch)
treeb4eff171ca55eb9a4cb1d9fdfd9f6638848e051c /Makefile.am
parent9b45848a88af4ae202bce346062a7c8db9bc6a66 (diff)
downloadconnman-acedf9d49b9a326771aeec755179e3ede3872cdd.tar.gz
connman-acedf9d49b9a326771aeec755179e3ede3872cdd.tar.bz2
connman-acedf9d49b9a326771aeec755179e3ede3872cdd.zip
selinux: Add Type Enforcement rule compilation
The SELinux rules are needed for VPN. They allow various vpn clients to send notifications to connman-vpnd via net.connman.Task dbus interface if the connman processes are run under systemd and the system is in enforcing mode.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b22213ee..21d820e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -377,6 +377,16 @@ else
endif
endif
+if SELINUX
+if VPN
+EXTRA_DIST += connman-task.pp
+CLEANFILES += connman-task.pp
+endif
+
+connman-task.pp: vpn/connman-task.te
+ make -f /usr/share/selinux/devel/Makefile
+endif
+
include/connman/version.h: include/version.h
$(AM_V_at)$(MKDIR_P) include/connman
$(AM_V_GEN)$(LN_S) $(abs_top_builddir)/$< $@