summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Wagner <daniel.wagner@bmw-carit.de>2013-03-12 18:16:33 +0100
committerPatrik Flykt <patrik.flykt@linux.intel.com>2013-03-18 14:31:25 +0200
commit516813cd4372bef22681137adf9d13c985bb7b99 (patch)
tree970abceba43d30f6b31838aa70c54345e818bfa5 /Makefile.am
parent1838dd68416a52ab47b9c7e42f4442c093989174 (diff)
downloadconnman-516813cd4372bef22681137adf9d13c985bb7b99.tar.gz
connman-516813cd4372bef22681137adf9d13c985bb7b99.tar.bz2
connman-516813cd4372bef22681137adf9d13c985bb7b99.zip
test-session: Move file to tools and rename it to session-test
These tests depens on ConnMan running and therefore not really a unit tests. Let's move it to tools.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b302758..87211230 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -266,7 +266,7 @@ noinst_PROGRAMS += tools/supplicant-test \
tools/dbus-test tools/polkit-test \
tools/iptables-test tools/tap-test tools/wpad-test \
tools/stats-tool tools/private-network-test \
- unit/test-session unit/test-ippool \
+ tools/session-test unit/test-ippool \
tools/iptables-unit
tools_supplicant_test_SOURCES = $(gdbus_sources) tools/supplicant-test.c \
@@ -300,11 +300,10 @@ tools_iptables_test_LDADD = @GLIB_LIBS@ @XTABLES_LIBS@
tools_private_network_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
-unit_test_session_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
- unit/test-session.c unit/utils.c unit/manager-api.c \
- unit/session-api.c unit/test-connman.h
-unit_test_session_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ -ldl
-unit_objects += $(unit_test_session_OBJECTS)
+tools_session_test_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
+ tools/session-test.c tools/session-utils.c tools/manager-api.c \
+ tools/session-api.c tools/session-test.h
+tools_session_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ -ldl
unit_test_ippool_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
src/ippool.c unit/test-ippool.c