summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJukka Rissanen <jukka.rissanen@linux.intel.com>2012-11-12 14:07:36 +0200
committerPatrik Flykt <patrik.flykt@linux.intel.com>2012-11-23 12:58:51 +0200
commit2023b90de4066fe2cf28b48bfca58c35c92aab20 (patch)
tree3851fcd87a156051c7c66c0276d72a5f44ef78b0 /Makefile.am
parent8bcd6b1b075bf2024ce2ba422e1f19d2f9f24652 (diff)
downloadconnman-2023b90de4066fe2cf28b48bfca58c35c92aab20.tar.gz
connman-2023b90de4066fe2cf28b48bfca58c35c92aab20.tar.bz2
connman-2023b90de4066fe2cf28b48bfca58c35c92aab20.zip
agent: Split agent code into generic and service specific parts
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index ff329330..b22213ee 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,7 @@ include_HEADERS = include/types.h include/log.h include/plugin.h \
include/resolver.h include/ipconfig.h \
include/device.h include/network.h include/inet.h \
include/storage.h include/provision.h \
- include/session.h include/ipaddress.h
+ include/session.h include/ipaddress.h include/agent.h
nodist_include_HEADERS = include/version.h
@@ -86,7 +86,7 @@ src_connmand_SOURCES = $(gdbus_sources) $(gdhcp_sources) $(gweb_sources) \
src/error.c src/plugin.c src/task.c \
src/device.c src/network.c src/connection.c \
src/manager.c src/service.c \
- src/clock.c src/timezone.c \
+ src/clock.c src/timezone.c src/agent-connman.c \
src/agent.c src/notifier.c src/provider.c \
src/resolver.c src/ipconfig.c src/detect.c src/inet.c \
src/dhcp.c src/dhcpv6.c src/rtnl.c src/proxy.c \
@@ -121,7 +121,7 @@ vpn_connman_vpnd_SOURCES = $(gdbus_sources) $(builtin_vpn_sources) \
vpn/vpn-manager.c vpn/vpn-provider.c \
vpn/vpn-provider.h vpn/vpn-rtnl.h \
vpn/vpn-ipconfig.c src/inet.c vpn/vpn-rtnl.c \
- src/dbus.c src/storage.c src/ipaddress.c
+ src/dbus.c src/storage.c src/ipaddress.c src/agent.c
vpn_connman_vpnd_LDADD = $(builtin_vpn_libadd) @GLIB_LIBS@ @DBUS_LIBS@ \
@GNUTLS_LIBS@ -lresolv -ldl