summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Wagner <daniel.wagner@bmw-carit.de>2013-03-18 16:18:12 +0100
committerPatrik Flykt <patrik.flykt@linux.intel.com>2013-03-19 15:53:23 +0200
commitfd7600c2cbebb377124d1aab6a4a2eecc46e14d1 (patch)
tree2b79881fecca15f188065c987033038ef17289ae /Makefile.am
parent3b0ff968ff195e8551587e10cb3f1b19a1aa4050 (diff)
downloadconnman-fd7600c2cbebb377124d1aab6a4a2eecc46e14d1.tar.gz
connman-fd7600c2cbebb377124d1aab6a4a2eecc46e14d1.tar.bz2
connman-fd7600c2cbebb377124d1aab6a4a2eecc46e14d1.zip
iptables-unit: Check if rules are inserted/removed
Optionally use iptables-save to check if the rules are installed or removed on the system instead of relying only on the returned iptables error code. Do notice that running tools/iptables-unit will modify and delete existing iptables firewall rules on your system. Use iptables-unit with caution!
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5d5f63a7..d54c6935 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -309,6 +309,8 @@ tools_session_test_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
tools/session-api.c tools/session-test.h
tools_session_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ -ldl
+tools_iptables_unit_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@ @XTABLES_CFLAGS@ \
+ -DIPTABLES_SAVE=\""${IPTABLES_SAVE}"\"
tools_iptables_unit_SOURCES = $(gdbus_sources) src/log.c \
src/iptables.c src/nat.c tools/iptables-unit.c
tools_iptables_unit_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ @XTABLES_LIBS@ -ldl