summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJukka Rissanen <jukka.rissanen@linux.intel.com>2013-04-05 12:33:09 +0300
committerPatrik Flykt <patrik.flykt@linux.intel.com>2013-04-05 16:05:59 +0300
commit2d16b66f1992e29712de2cb3686075b2bede57d9 (patch)
tree882e7bbfff460aa04d712744a1ce5904e42a07d9 /Makefile.am
parent385694bb737157ca1b0b9dd153dde516b2ce0b7a (diff)
downloadconnman-2d16b66f1992e29712de2cb3686075b2bede57d9.tar.gz
connman-2d16b66f1992e29712de2cb3686075b2bede57d9.tar.bz2
connman-2d16b66f1992e29712de2cb3686075b2bede57d9.zip
tools: Add unit test for dnsproxy
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4ae08529..dfe23b64 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -268,7 +268,8 @@ noinst_PROGRAMS += tools/supplicant-test \
tools/dbus-test tools/polkit-test \
tools/iptables-test tools/tap-test tools/wpad-test \
tools/stats-tool tools/private-network-test \
- tools/session-test tools/iptables-unit
+ tools/session-test tools/iptables-unit \
+ tools/dnsproxy-unit
tools_supplicant_test_SOURCES = $(gdbus_sources) tools/supplicant-test.c \
tools/supplicant-dbus.h tools/supplicant-dbus.c \
@@ -313,6 +314,9 @@ tools_iptables_unit_SOURCES = $(gdbus_sources) src/log.c \
src/iptables.c src/firewall.c src/nat.c tools/iptables-unit.c
tools_iptables_unit_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ @XTABLES_LIBS@ -ldl
+tools_dnsproxy_unit_SOURCES = tools/dnsproxy-unit.c
+tools_dnsproxy_unit_LDADD = @GLIB_LIBS@
+
endif
test_scripts = test/get-state test/list-services \