summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2009-08-23 19:09:00 -0700
committerMarcel Holtmann <marcel@holtmann.org>2009-08-23 19:09:00 -0700
commit35a680636b823436a48d2ca970ce730453520396 (patch)
tree202bdfdf9bbc9c28161a3e1b31067e5f3551ff0a /Makefile.am
parentf5ed99fed497c6cd5811de767dcfd251cbae0bea (diff)
downloadconnman-35a680636b823436a48d2ca970ce730453520396.tar.gz
connman-35a680636b823436a48d2ca970ce730453520396.tar.bz2
connman-35a680636b823436a48d2ca970ce730453520396.zip
Fix GAtChat compilation and linking
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 4 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index d811c84f..6579a818 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,11 +22,6 @@ local_headers = $(foreach file,$(include_HEADERS) $(nodist_include_HEADERS) \
gdbus_sources = gdbus/gdbus.h gdbus/mainloop.c gdbus/object.c gdbus/watch.c
-gatchat_sources = gatchat/gatchat.h gatchat/gatchat.c \
- gatchat/gatresult.h gatchat/gatresult.c \
- gatchat/gatsyntax.h gatchat/gatsyntax.c \
- gatchat/ringbuffer.h gatchat/ringbuffer.c
-
if DATAFILES
dbusdir = @DBUS_DATADIR@
@@ -46,7 +41,7 @@ noinst_PROGRAMS =
sbin_PROGRAMS = src/connmand
-src_connmand_SOURCES = $(gdbus_sources) $(gatchat_sources) $(builtin_sources) \
+src_connmand_SOURCES = $(gdbus_sources) $(builtin_sources) \
src/main.c src/connman.h src/log.c src/selftest.c \
src/error.c src/plugin.c src/task.c src/element.c \
src/device.c src/network.c src/connection.c \
@@ -88,8 +83,7 @@ AM_CFLAGS = @UDEV_CFLAGS@ @NETLINK_CFLAGS@ @DBUS_CFLAGS@ \
-DSCRIPTDIR=\""$(scriptdir)"\" \
-DSTORAGEDIR=\""$(storagedir)\""
-INCLUDES = -I$(top_builddir)/include -I$(top_builddir)/src \
- -I$(srcdir)/gdbus -I$(srcdir)/gatchat
+INCLUDES = -I$(builddir)/include -I$(builddir)/src -I$(srcdir)/gdbus
EXTRA_DIST = src/genbuiltin src/connman-dbus.conf src/connman-polkit.conf
@@ -167,7 +161,8 @@ src/builtin.h: src/genbuiltin $(builtin_sources)
$(AM_V_GEN)$(srcdir)/src/genbuiltin $(builtin_modules) > $@
src/connman.exp: $(src_connmand_OBJECTS)
- $(AM_V_GEN)nm -B $^ | awk '{ print $$3 }' | sort -u | grep -E -e '^connman_' > $@
+ $(AM_V_GEN)nm -B $^ | awk '{ print $$3 }' | sort -u | \
+ grep -E -e '^connman_' -e '^g_dbus_' > $@
src/connman.ver: src/connman.exp
$(AM_V_at)echo "{ global:" > $@