summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@profusion.mobi>2012-10-02 11:57:54 -0300
committerPatrik Flykt <patrik.flykt@linux.intel.com>2012-10-03 11:22:52 +0300
commit8bc3846ebe4fdd935326e84926c3556a903da940 (patch)
treebebbe5424b374cabf6285c1033437eb0d1f27fc8 /Makefile.am
parentc4b5683576c11b2ae8e54da0e1bc03b6c1c67998 (diff)
downloadconnman-8bc3846ebe4fdd935326e84926c3556a903da940.tar.gz
connman-8bc3846ebe4fdd935326e84926c3556a903da940.tar.bz2
connman-8bc3846ebe4fdd935326e84926c3556a903da940.zip
build: Fix missing -lrt for clock_gettime()
librt is needed for using clock_gettime(): /usr/bin/ld: src/ntp.o: undefined reference to symbol 'clock_gettime@@GLIBC_2.2.5' /usr/bin/ld: note: 'clock_gettime@@GLIBC_2.2.5' is defined in DSO /usr/lib/librt.so.1 so try adding it to the linker command line /usr/lib/librt.so.1: could not read symbols: Invalid operation collect2: error: ld returned 1 exit status
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8693752d..b05d4f02 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,7 +88,7 @@ src_connmand_SOURCES = $(gdbus_sources) $(gdhcp_sources) $(gweb_sources) \
src/ippool.c src/bridge.c src/nat.c
src_connmand_LDADD = $(builtin_libadd) @GLIB_LIBS@ @DBUS_LIBS@ \
- @XTABLES_LIBS@ @GNUTLS_LIBS@ -lresolv -ldl
+ @XTABLES_LIBS@ @GNUTLS_LIBS@ -lresolv -ldl -lrt
src_connmand_LDFLAGS = -Wl,--export-dynamic \
-Wl,--version-script=$(srcdir)/src/connman.ver