summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2010-07-14 02:29:01 +0200
committerSamuel Ortiz <sameo@linux.intel.com>2010-07-14 02:30:11 +0200
commit0378026fe391c3312b2ad263af77c2f5639c5dd8 (patch)
treebbbfd36d8c467705fd637faceca3ff1ad5f27102 /Makefile.am
parentcffd863e8a8d70d2d602ca5a43099605d230dd4b (diff)
downloadconnman-0378026fe391c3312b2ad263af77c2f5639c5dd8.tar.gz
connman-0378026fe391c3312b2ad263af77c2f5639c5dd8.tar.bz2
connman-0378026fe391c3312b2ad263af77c2f5639c5dd8.zip
iptables test program
This piece of code allows to add a -m quota -j DROP rule to a user defined chain.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ea948521..96d7a3ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -117,7 +117,8 @@ endif
if TOOLS
noinst_PROGRAMS += tools/wifi-scan tools/supplicant-test tools/dbus-test \
tools/addr-test tools/tap-test tools/resolv-test \
- tools/polkit-test tools/portal-test
+ tools/polkit-test tools/portal-test \
+ tools/iptables-test
tools_wifi_scan_LDADD = @GLIB_LIBS@ @NETLINK_LIBS@
@@ -134,6 +135,8 @@ tools_resolv_test_LDADD = -lresolv
tools_polkit_test_LDADD = @DBUS_LIBS@
tools_portal_test_LDADD = @GLIB_LIBS@
+
+tools_iptables_test_LDADD = @GLIB_LIBS@ @NETLINK_LIBS@ -liptc -lxtables
endif
test_scripts = test/get-state test/list-profiles test/list-services \