summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2010-09-15 23:42:16 +0200
committerSamuel Ortiz <sameo@linux.intel.com>2010-09-20 15:14:15 +0200
commitd6b6fb3003a42e857fbd969e0ccfc771f4fc8398 (patch)
tree6632479eb88c1bc8a57af10d97aabe47ef1e2cc0 /Makefile.am
parentc9f804e1cce4290834b39e937e2a228960e88869 (diff)
downloadconnman-d6b6fb3003a42e857fbd969e0ccfc771f4fc8398.tar.gz
connman-d6b6fb3003a42e857fbd969e0ccfc771f4fc8398.tar.bz2
connman-d6b6fb3003a42e857fbd969e0ccfc771f4fc8398.zip
GSupplicant intial commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3de71869..f5158ed8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,6 +32,9 @@ gresolv_sources = gresolv/gresolv.h gresolv/gresolv.c
gweb_sources = gweb/gweb.h gweb/gweb.c
+gsupplicant_sources = gsupplicant/gsupplicant.h gsupplicant/dbus.h \
+ gsupplicant/supplicant.c gsupplicant/dbus.c
+
if DATAFILES
dbusdir = @DBUS_DATADIR@
@@ -72,6 +75,10 @@ else
src_connmand_SOURCES += src/udev-compat.c
endif
+if WIFI
+src_connmand_SOURCES += $(gsupplicant_sources)
+endif
+
src_connmand_LDADD = $(builtin_libadd) @GLIB_LIBS@ @DBUS_LIBS@ \
@CAPNG_LIBS@ @UDEV_LIBS@ -lresolv -ldl