summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKalle Valo <kalle.valo@canonical.com>2010-06-04 13:54:12 +0300
committerSamuel Ortiz <sameo@linux.intel.com>2010-06-04 15:14:43 +0200
commit9f7afb230fbe23f5cb58829c2f83ac8554abd6ad (patch)
treef2454a48c7934a865b76213f6b400839681e8e18 /Makefile.am
parent08612ccb23bd3efd266e0c17d098fc250c6860b5 (diff)
downloadconnman-9f7afb230fbe23f5cb58829c2f83ac8554abd6ad.tar.gz
connman-9f7afb230fbe23f5cb58829c2f83ac8554abd6ad.tar.bz2
connman-9f7afb230fbe23f5cb58829c2f83ac8554abd6ad.zip
Fix make clean
Running make clean twice in a row fails with error: make: *** No rule to make target `include/connman', needed by `clean-local'. Stop. Fix it by moving the target as an argument for rm.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e98e8b4..41fffae5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -227,5 +227,5 @@ include/connman/%.h: include/%.h
$(AM_V_at)$(MKDIR_P) include/connman
$(AM_V_GEN)$(LN_S) $(abs_top_srcdir)/$< $@
-clean-local: include/connman
- @$(RM) -r $<
+clean-local:
+ @$(RM) -rf include/connman