summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2010-10-23 00:09:30 +0200
committerSamuel Ortiz <sameo@linux.intel.com>2010-10-23 00:09:30 +0200
commitf60ec47df7c4d4b0ee0f2557981e86fe74eb7423 (patch)
treed776efc6e17f6a9518681f0e81700ef6c26bd37d /Makefile.am
parent8b49f33573921c27511cb60f7384a48ac3aaa7d4 (diff)
downloadconnman-f60ec47df7c4d4b0ee0f2557981e86fe74eb7423.tar.gz
connman-f60ec47df7c4d4b0ee0f2557981e86fe74eb7423.tar.bz2
connman-f60ec47df7c4d4b0ee0f2557981e86fe74eb7423.zip
iptables: Replace iptables-test program
The new iptables-test no longer links against the unstable libiptc library. A link against libxtables is still necessary as the iptables extensions are only registered against iptables through this library. Not using it would mean replicating any of the extensions ConnMan could potentially need.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 04189d76..cffebd0e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,7 +101,7 @@ build_plugindir = $(plugindir)
build_scriptdir = $(scriptdir)
endif
-AM_CFLAGS = @IPTC_CFLAGS@ @NETLINK_CFLAGS@ @CAPNG_CFLAGS@ \
+AM_CFLAGS = @XTABLES_CFLAGS@ @NETLINK_CFLAGS@ @CAPNG_CFLAGS@ \
@DBUS_CFLAGS@ @GLIB_CFLAGS@ $(builtin_cflags) \
-DCONNMAN_PLUGIN_BUILTIN \
-DSTATEDIR=\""$(statedir)"\" \
@@ -160,7 +160,7 @@ tools_polkit_test_LDADD = @DBUS_LIBS@
tools_portal_test_LDADD = @GLIB_LIBS@
-tools_iptables_test_LDADD = @IPTC_LIBS@ -lip4tc -lxtables
+tools_iptables_test_LDADD = @GLIB_LIBS@ @XTABLES_LIBS@
if DHCLIENT
noinst_PROGRAMS += tools/dhclient-test