summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2011-06-08 07:28:16 +0200
committerMarcel Holtmann <marcel@holtmann.org>2011-06-08 07:28:16 +0200
commit113894a7cd81d1b8a2456aa51afd3982e99648b4 (patch)
tree8108e8237bde16d8939335033854af78cf40e385 /Makefile.am
parentb21c7ce892d3b8a8036771c49733c78da11beea2 (diff)
downloadconnman-113894a7cd81d1b8a2456aa51afd3982e99648b4.tar.gz
connman-113894a7cd81d1b8a2456aa51afd3982e99648b4.tar.bz2
connman-113894a7cd81d1b8a2456aa51afd3982e99648b4.zip
tools: Add utility for testing AF_ALG kernel interface
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 102e6782..76a75abc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -145,7 +145,7 @@ noinst_PROGRAMS += tools/wispr tools/wifi-scan tools/supplicant-test \
tools/dbus-test tools/polkit-test \
tools/iptables-test tools/tap-test tools/wpad-test \
tools/stats-tool tools/private-network-test \
- unit/test-session
+ tools/alg-test unit/test-session
tools_wispr_SOURCES = $(gweb_sources) tools/wispr.c
tools_wispr_LDADD = @GLIB_LIBS@ @GNUTLS_LIBS@ -lresolv
@@ -183,6 +183,8 @@ tools_iptables_test_LDADD = @GLIB_LIBS@ @XTABLES_LIBS@
tools_private_network_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
+tools_alg_test_LDADD = @GLIB_LIBS@
+
unit_test_session_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
unit/test-session.c unit/utils.c unit/manager-api.c \
unit/session-api.c