summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2010-04-01 12:17:36 +0200
committerSamuel Ortiz <sameo@linux.intel.com>2010-04-03 02:02:46 +0200
commitbb5932d21d06aa4e73d5a08c4122a025c1522da8 (patch)
tree7089458d2f9d2815a25f324ceb9212d5314ac744 /Makefile.am
parent06309b134249d56ceceeda90967ba4b3b0b76682 (diff)
downloadconnman-bb5932d21d06aa4e73d5a08c4122a025c1522da8.tar.gz
connman-bb5932d21d06aa4e73d5a08c4122a025c1522da8.tar.bz2
connman-bb5932d21d06aa4e73d5a08c4122a025c1522da8.zip
Add session support
The session layer allows 3rd party applications to request a network session from connman. The only thing applications need to specify is the type of network they're looking for, a.k.a. the network bearer. An unspecified bearer means picking the best available service.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e8d9b2c6..64c02644 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,7 +53,8 @@ src_connmand_SOURCES = $(gdbus_sources) $(builtin_sources) \
src/ipv4.c src/dhcp.c src/rtnl.c src/inet.c \
src/utsname.c src/timeserver.c src/rfkill.c \
src/wifi.c src/storage.c src/dbus.c src/config.c \
- src/technology.c src/counter.c src/location.c
+ src/technology.c src/counter.c src/location.c \
+ src/session.c
if UDEV
src_connmand_SOURCES += src/udev.c