summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Wagner <daniel.wagner@bmw-carit.de>2011-06-07 15:42:21 +0200
committerDaniel Wagner <daniel.wagner@bmw-carit.de>2011-06-07 15:42:57 +0200
commit79c3c564d2eed702c2b095b12d95946eb2fba8e2 (patch)
tree7fc11b0f73eff32eeda39167c9cf3684f1dc465f /Makefile.am
parent3973603a07be70d0a5a0dfda88d71bc9252a9c0a (diff)
downloadconnman-79c3c564d2eed702c2b095b12d95946eb2fba8e2.tar.gz
connman-79c3c564d2eed702c2b095b12d95946eb2fba8e2.tar.bz2
connman-79c3c564d2eed702c2b095b12d95946eb2fba8e2.zip
unit: Add test-session
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 446a26a8..6e661c75 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,6 +60,8 @@ builtin_cflags =
noinst_PROGRAMS =
+unit_objects =
+
sbin_PROGRAMS = src/connmand
src_connmand_SOURCES = $(gdbus_sources) $(gdhcp_sources) \
@@ -142,7 +144,8 @@ noinst_PROGRAMS += tools/wispr tools/wifi-scan tools/supplicant-test \
tools/addr-test tools/web-test tools/resolv-test \
tools/dbus-test tools/polkit-test \
tools/iptables-test tools/tap-test tools/wpad-test \
- tools/stats-tool tools/private-network-test
+ tools/stats-tool tools/private-network-test \
+ unit/test-session
tools_wispr_SOURCES = $(gweb_sources) tools/wispr.c
tools_wispr_LDADD = @GLIB_LIBS@ @GNUTLS_LIBS@ -lresolv
@@ -179,6 +182,10 @@ tools_polkit_test_LDADD = @DBUS_LIBS@
tools_iptables_test_LDADD = @GLIB_LIBS@ @XTABLES_LIBS@
tools_private_network_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
+
+unit_test_session_SOURCES = $(gdbus_sources) unit/test-session.c
+unit_test_session_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
+unit_objects += $(unit_test_session_OBJECTS)
endif
test_scripts = test/get-state test/list-profiles test/list-services \