summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2010-07-29 16:13:58 -0700
committerMarcel Holtmann <marcel@holtmann.org>2010-07-29 16:13:58 -0700
commit9c8149957d6cdeba6d8c83200645054852a75b49 (patch)
treeac485027cb534d679c277b3a1c6a5c4795bf464d /Makefile.am
parent404a19819b42ed02929cca65ffb5a25307783d84 (diff)
downloadconnman-9c8149957d6cdeba6d8c83200645054852a75b49.tar.gz
connman-9c8149957d6cdeba6d8c83200645054852a75b49.tar.bz2
connman-9c8149957d6cdeba6d8c83200645054852a75b49.zip
Add simple test tool for running WPAD DNS queries
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 68f5c115..875da95a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -124,7 +124,7 @@ if TOOLS
noinst_PROGRAMS += tools/wifi-scan tools/supplicant-test tools/dhcp-test \
tools/addr-test tools/tap-test tools/resolv-test \
tools/dbus-test tools/polkit-test tools/portal-test \
- tools/iptables-test tools/dhclient-test
+ tools/iptables-test tools/dhclient-test tools/wpad-test
tools_wifi_scan_LDADD = @GLIB_LIBS@ @NETLINK_LIBS@
@@ -136,6 +136,9 @@ tools_supplicant_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
tools_resolv_test_SOURCES = $(gresolv_sources) tools/resolv-test.c
tools_resolv_test_LDADD = @GLIB_LIBS@ -lresolv
+tools_wpad_test_SOURCES = $(gresolv_sources) tools/wpad-test.c
+tools_wpad_test_LDADD = @GLIB_LIBS@ -lresolv
+
tools_dhcp_test_SOURCES = $(gdhcp_sources) tools/dhcp-test.c
tools_dhcp_test_LDADD = @GLIB_LIBS@