summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2010-07-28 13:25:22 -0700
committerMarcel Holtmann <marcel@holtmann.org>2010-07-28 13:25:22 -0700
commit7804013bd84c430cf44cbbc23b9848632d67ee83 (patch)
treef98b2354e4cc3c79b0b4b9f3969471874f19dc51 /Makefile.am
parent50c93bb8f825f9796ff2cf95f321276ccde592b2 (diff)
downloadconnman-7804013bd84c430cf44cbbc23b9848632d67ee83.tar.gz
connman-7804013bd84c430cf44cbbc23b9848632d67ee83.tar.bz2
connman-7804013bd84c430cf44cbbc23b9848632d67ee83.zip
Add tool for standalone dhclient testing
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 50d80de7..68f5c115 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -124,7 +124,7 @@ if TOOLS
noinst_PROGRAMS += tools/wifi-scan tools/supplicant-test tools/dhcp-test \
tools/addr-test tools/tap-test tools/resolv-test \
tools/dbus-test tools/polkit-test tools/portal-test \
- tools/iptables-test
+ tools/iptables-test tools/dhclient-test
tools_wifi_scan_LDADD = @GLIB_LIBS@ @NETLINK_LIBS@
@@ -147,6 +147,9 @@ tools_polkit_test_LDADD = @DBUS_LIBS@
tools_portal_test_LDADD = @GLIB_LIBS@
tools_iptables_test_LDADD = @IPTC_LIBS@ -lip4tc -lxtables
+
+tools_dhclient_test_SOURCES = $(gdbus_sources) tools/dhclient-test.c
+tools_dhclient_test_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
endif
test_scripts = test/get-state test/list-profiles test/list-services \