summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index dfc4a1c..5a14884 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,4 @@
#
-# $Id: Makefile.am,v 1.2 2003-11-05 05:39:58 keithp Exp $
-#
# Copyright © 2003 Keith Packard, Noah Levitt
#
# Permission to use, copy, modify, distribute, and sell this software and its
@@ -29,7 +27,17 @@ composite_HEADERS = \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = compositeproto.pc
-compositedocdir = $(datadir)/doc/$(PACKAGE)
-compositedoc_DATA = compositeproto.txt
+dist_doc_DATA = compositeproto.txt
+
+
+MAINTAINERCLEANFILES = ChangeLog INSTALL
+
+.PHONY: ChangeLog INSTALL
+
+INSTALL:
+ $(INSTALL_CMD)
+
+ChangeLog:
+ $(CHANGELOG_CMD)
-EXTRA_DIST = autogen.sh compositeproto.pc.in $(compositedoc_DATA)
+dist-hook: ChangeLog INSTALL