summaryrefslogtreecommitdiff
path: root/Utilities/Doxygen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Utilities/Doxygen/CMakeLists.txt')
-rw-r--r--Utilities/Doxygen/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/Utilities/Doxygen/CMakeLists.txt b/Utilities/Doxygen/CMakeLists.txt
index 2430391fd..813e34daf 100644
--- a/Utilities/Doxygen/CMakeLists.txt
+++ b/Utilities/Doxygen/CMakeLists.txt
@@ -13,27 +13,27 @@
#
# Build the documentation
#
-INCLUDE (${CMAKE_ROOT}/Modules/Documentation.cmake OPTIONAL)
+include (${CMAKE_ROOT}/Modules/Documentation.cmake OPTIONAL)
-IF (BUILD_DOCUMENTATION)
+if (BUILD_DOCUMENTATION)
#
# Configure the script and the doxyfile, then add target
#
- IF(NOT DOT_PATH)
- GET_FILENAME_COMPONENT(DOT_PATH ${DOT} PATH)
- ENDIF(NOT DOT_PATH)
+ if(NOT DOT_PATH)
+ get_filename_component(DOT_PATH ${DOT} PATH)
+ endif()
- CONFIGURE_FILE(
+ configure_file(
${CMake_SOURCE_DIR}/Utilities/Doxygen/doxyfile.in
${CMake_BINARY_DIR}/Utilities/Doxygen/doxyfile)
- CONFIGURE_FILE(
+ configure_file(
${CMake_SOURCE_DIR}/Utilities/Doxygen/doc_makeall.sh.in
${CMake_BINARY_DIR}/Utilities/Doxygen/doc_makeall.sh)
- ADD_CUSTOM_TARGET(DoxygenDoc
+ add_custom_target(DoxygenDoc
${BASH}
${CMake_BINARY_DIR}/Utilities/Doxygen/doc_makeall.sh)
-ENDIF (BUILD_DOCUMENTATION)
+endif ()