summaryrefslogtreecommitdiff
path: root/Tests/WarnUnusedCliUnused/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/WarnUnusedCliUnused/CMakeLists.txt')
-rw-r--r--Tests/WarnUnusedCliUnused/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/Tests/WarnUnusedCliUnused/CMakeLists.txt b/Tests/WarnUnusedCliUnused/CMakeLists.txt
index 7ed69bf3c..a149f043f 100644
--- a/Tests/WarnUnusedCliUnused/CMakeLists.txt
+++ b/Tests/WarnUnusedCliUnused/CMakeLists.txt
@@ -1,9 +1,9 @@
-cmake_minimum_required(VERSION 2.8)
+cmake_minimum_required(VERSION 3.14)
project(WarnUnusedCliUnused)
-set_directory_properties(PROPERTIES
- ADDITIONAL_MAKE_CLEAN_FILES "${CMAKE_BINARY_DIR}/CMakeCache.txt"
-)
+# Remove UNUSED_CLI_VARIABLE from the cache to trigger the
+# CMake warning message on re-builds as well.
+unset(UNUSED_CLI_VARIABLE CACHE)
add_library(dummy empty.cpp)