summaryrefslogtreecommitdiff
path: root/Tests/VariableUnusedViaUnset/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/VariableUnusedViaUnset/CMakeLists.txt')
-rw-r--r--Tests/VariableUnusedViaUnset/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/VariableUnusedViaUnset/CMakeLists.txt b/Tests/VariableUnusedViaUnset/CMakeLists.txt
new file mode 100644
index 000000000..4b4031da3
--- /dev/null
+++ b/Tests/VariableUnusedViaUnset/CMakeLists.txt
@@ -0,0 +1,8 @@
+# NOTE: Changing lines in here changes the test results since the first
+# instance shouldn't warn, but the second should and they have the same message
+
+# A warning should NOT be issued for this line:
+set(UNUSED_VARIABLE)
+# Warning should occur here:
+set(UNUSED_VARIABLE)
+message(STATUS "${UNUSED_VARIABLE}")