summaryrefslogtreecommitdiff
path: root/Tests/VariableUnusedViaSet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/VariableUnusedViaSet/CMakeLists.txt')
-rw-r--r--Tests/VariableUnusedViaSet/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/VariableUnusedViaSet/CMakeLists.txt b/Tests/VariableUnusedViaSet/CMakeLists.txt
new file mode 100644
index 000000000..0123ab221
--- /dev/null
+++ b/Tests/VariableUnusedViaSet/CMakeLists.txt
@@ -0,0 +1,4 @@
+set(UNUSED_VARIABLE)
+# Warning should occur here
+set(UNUSED_VARIABLE "Usage")
+message(STATUS "${UNUSED_VARIABLE}")