summaryrefslogtreecommitdiff
path: root/Tests/VSResource/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/VSResource/CMakeLists.txt')
-rw-r--r--Tests/VSResource/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/VSResource/CMakeLists.txt b/Tests/VSResource/CMakeLists.txt
index 718e62441..fb47c7e13 100644
--- a/Tests/VSResource/CMakeLists.txt
+++ b/Tests/VSResource/CMakeLists.txt
@@ -56,3 +56,10 @@ endif()
set_property(TARGET VSResource
PROPERTY VS_GLOBAL_CMakeTestVsGlobalVariable "test val")
+
+if(CMAKE_GENERATOR MATCHES "Ninja|Visual Studio")
+ cmake_policy(PUSH)
+ cmake_policy(SET CMP0037 OLD)
+ add_library("My ResourceLib" lib.cpp lib.rc)
+ cmake_policy(POP)
+endif()