summaryrefslogtreecommitdiff
path: root/Tests/VSGNUFortran/subdir/fortran/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/VSGNUFortran/subdir/fortran/CMakeLists.txt')
-rw-r--r--Tests/VSGNUFortran/subdir/fortran/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/VSGNUFortran/subdir/fortran/CMakeLists.txt b/Tests/VSGNUFortran/subdir/fortran/CMakeLists.txt
index abd062836..950ec25d5 100644
--- a/Tests/VSGNUFortran/subdir/fortran/CMakeLists.txt
+++ b/Tests/VSGNUFortran/subdir/fortran/CMakeLists.txt
@@ -43,4 +43,9 @@ if(CMAKE_Fortran_COMPILER_ID MATCHES SunPro)
target_link_libraries(hello PRIVATE sunquad)
endif()
endif()
+elseif(CMAKE_Fortran_COMPILER_ID MATCHES Fujitsu)
+ # Fujitsu Fortran doesn't automatically link its runtime libraries into
+ # SOs
+ target_link_libraries(world PRIVATE fj90i fj90f fjsrcinfo)
+ target_link_libraries(hello PRIVATE fj90i fj90f fjsrcinfo)
endif()