summaryrefslogtreecommitdiff
path: root/Tests/Unset/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Unset/CMakeLists.txt')
-rw-r--r--Tests/Unset/CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/Tests/Unset/CMakeLists.txt b/Tests/Unset/CMakeLists.txt
index bacb6d21f..781da3fa6 100644
--- a/Tests/Unset/CMakeLists.txt
+++ b/Tests/Unset/CMakeLists.txt
@@ -5,51 +5,51 @@ project(Unset C)
set(x 42)
if(NOT x EQUAL 42)
message(FATAL_ERROR "x!=42")
-endif(NOT x EQUAL 42)
+endif()
if(NOT DEFINED x)
message(FATAL_ERROR "x should be defined!")
-endif(NOT DEFINED x)
+endif()
unset(x)
if(DEFINED x)
message(FATAL_ERROR "x should be undefined now!")
-endif(DEFINED x)
+endif()
# Local variable test unset via set()
set(x 43)
if(NOT x EQUAL 43)
message(FATAL_ERROR "x!=43")
-endif(NOT x EQUAL 43)
+endif()
set(x)
if(DEFINED x)
message(FATAL_ERROR "x should be undefined now!")
-endif(DEFINED x)
+endif()
# Cache variable
set(BAR "test" CACHE STRING "documentation")
if(NOT DEFINED BAR)
message(FATAL_ERROR "BAR not defined")
-endif(NOT DEFINED BAR)
+endif()
# Test interaction of cache entries with variables.
set(BAR "test-var")
if(NOT "$CACHE{BAR}" STREQUAL "test")
message(FATAL_ERROR "\$CACHE{BAR} changed by variable BAR")
-endif(NOT "$CACHE{BAR}" STREQUAL "test")
+endif()
if(NOT "${BAR}" STREQUAL "test-var")
message(FATAL_ERROR "\${BAR} not separate from \$CACHE{BAR}")
-endif(NOT "${BAR}" STREQUAL "test-var")
+endif()
unset(BAR)
if(NOT "${BAR}" STREQUAL "test")
message(FATAL_ERROR "\${BAR} does not fall through to \$CACHE{BAR}")
-endif(NOT "${BAR}" STREQUAL "test")
+endif()
# Test unsetting of CACHE entry.
unset(BAR CACHE)
if(DEFINED BAR)
message(FATAL_ERROR "BAR still defined")
-endif(DEFINED BAR)
+endif()
add_executable(Unset unset.c)