summaryrefslogtreecommitdiff
path: root/Tests/SystemInformation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/SystemInformation/CMakeLists.txt')
-rw-r--r--Tests/SystemInformation/CMakeLists.txt74
1 files changed, 37 insertions, 37 deletions
diff --git a/Tests/SystemInformation/CMakeLists.txt b/Tests/SystemInformation/CMakeLists.txt
index c4285758e..838fd4aa1 100644
--- a/Tests/SystemInformation/CMakeLists.txt
+++ b/Tests/SystemInformation/CMakeLists.txt
@@ -1,61 +1,61 @@
cmake_minimum_required (VERSION 2.6)
-PROJECT(SystemInformation)
+project(SystemInformation)
-INCLUDE_DIRECTORIES("This does not exists")
-GET_DIRECTORY_PROPERTY(incl INCLUDE_DIRECTORIES)
-SET_DIRECTORY_PROPERTIES(PROPERTIES INCLUDE_DIRECTORIES "${SystemInformation_BINARY_DIR};${SystemInformation_SOURCE_DIR}")
+include_directories("This does not exists")
+get_directory_property(incl INCLUDE_DIRECTORIES)
+set_directory_properties(PROPERTIES INCLUDE_DIRECTORIES "${SystemInformation_BINARY_DIR};${SystemInformation_SOURCE_DIR}")
-MESSAGE("To prevent CTest from stripping output, you have to display: CTEST_FULL_OUTPUT")
+message("To prevent CTest from stripping output, you have to display: CTEST_FULL_OUTPUT")
-CONFIGURE_FILE(${SystemInformation_SOURCE_DIR}/SystemInformation.in
+configure_file(${SystemInformation_SOURCE_DIR}/SystemInformation.in
${SystemInformation_BINARY_DIR}/SystemInformation.out)
-CONFIGURE_FILE(${SystemInformation_SOURCE_DIR}/DumpInformation.h.in
+configure_file(${SystemInformation_SOURCE_DIR}/DumpInformation.h.in
${SystemInformation_BINARY_DIR}/DumpInformation.h)
-ADD_EXECUTABLE(SystemInformation DumpInformation.cxx)
+add_executable(SystemInformation DumpInformation.cxx)
-MACRO(FOO args)
- MESSAGE("Test macro")
-ENDMACRO(FOO)
+macro(FOO args)
+ message("Test macro")
+endmacro()
FOO(lala)
-FILE(WRITE ${CMAKE_CURRENT_BINARY_DIR}/AllVariables.txt "")
-GET_CMAKE_PROPERTY(res VARIABLES)
-FOREACH(var ${res})
- FILE(APPEND ${CMAKE_CURRENT_BINARY_DIR}/AllVariables.txt
+file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/AllVariables.txt "")
+get_cmake_property(res VARIABLES)
+foreach(var ${res})
+ file(APPEND ${CMAKE_CURRENT_BINARY_DIR}/AllVariables.txt
"${var} \"${${var}}\"\n")
-ENDFOREACH(var ${res})
+endforeach()
-FILE(WRITE ${CMAKE_CURRENT_BINARY_DIR}/AllCommands.txt "")
-GET_CMAKE_PROPERTY(res COMMANDS)
-FOREACH(var ${res})
- FILE(APPEND ${CMAKE_CURRENT_BINARY_DIR}/AllCommands.txt
+file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/AllCommands.txt "")
+get_cmake_property(res COMMANDS)
+foreach(var ${res})
+ file(APPEND ${CMAKE_CURRENT_BINARY_DIR}/AllCommands.txt
"${var}\n")
-ENDFOREACH(var ${res})
+endforeach()
-FILE(WRITE ${CMAKE_CURRENT_BINARY_DIR}/AllMacros.txt "")
-GET_CMAKE_PROPERTY(res MACROS)
-FOREACH(var ${res})
- FILE(APPEND ${CMAKE_CURRENT_BINARY_DIR}/AllMacros.txt
+file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/AllMacros.txt "")
+get_cmake_property(res MACROS)
+foreach(var ${res})
+ file(APPEND ${CMAKE_CURRENT_BINARY_DIR}/AllMacros.txt
"${var}\n")
-ENDFOREACH(var ${res})
+endforeach()
-FILE(WRITE ${CMAKE_CURRENT_BINARY_DIR}/OtherProperties.txt "")
-GET_DIRECTORY_PROPERTY(res INCLUDE_DIRECTORIES)
-FOREACH(var ${res})
- FILE(APPEND ${CMAKE_CURRENT_BINARY_DIR}/OtherProperties.txt
+file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/OtherProperties.txt "")
+get_directory_property(res INCLUDE_DIRECTORIES)
+foreach(var ${res})
+ file(APPEND ${CMAKE_CURRENT_BINARY_DIR}/OtherProperties.txt
"INCLUDE_DIRECTORY: ${var}\n")
-ENDFOREACH(var)
+endforeach()
-GET_DIRECTORY_PROPERTY(res LINK_DIRECTORIES)
-FOREACH(var ${res})
- FILE(APPEND ${CMAKE_CURRENT_BINARY_DIR}/OtherProperties.txt
+get_directory_property(res LINK_DIRECTORIES)
+foreach(var ${res})
+ file(APPEND ${CMAKE_CURRENT_BINARY_DIR}/OtherProperties.txt
"LINK_DIRECTORIES: ${var}\n")
-ENDFOREACH(var)
+endforeach()
-GET_DIRECTORY_PROPERTY(res INCLUDE_REGULAR_EXPRESSION)
-FILE(APPEND ${CMAKE_CURRENT_BINARY_DIR}/OtherProperties.txt
+get_directory_property(res INCLUDE_REGULAR_EXPRESSION)
+file(APPEND ${CMAKE_CURRENT_BINARY_DIR}/OtherProperties.txt
"INCLUDE_REGULAR_EXPRESSION: ${res}\n")