summaryrefslogtreecommitdiff
path: root/Tests/SubDirSpaces/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/SubDirSpaces/CMakeLists.txt')
-rw-r--r--Tests/SubDirSpaces/CMakeLists.txt84
1 files changed, 42 insertions, 42 deletions
diff --git a/Tests/SubDirSpaces/CMakeLists.txt b/Tests/SubDirSpaces/CMakeLists.txt
index 879530b56..69f1d6833 100644
--- a/Tests/SubDirSpaces/CMakeLists.txt
+++ b/Tests/SubDirSpaces/CMakeLists.txt
@@ -1,16 +1,16 @@
cmake_minimum_required (VERSION 2.6)
-PROJECT(SUBDIR)
+project(SUBDIR)
# Some systems do not seem to support rpath with spaces.
-IF("${CMAKE_SYSTEM}" MATCHES "IRIX|QNX")
- SET(CMAKE_SKIP_BUILD_RPATH 1)
-ENDIF("${CMAKE_SYSTEM}" MATCHES "IRIX|QNX")
+if("${CMAKE_SYSTEM}" MATCHES "IRIX|QNX")
+ set(CMAKE_SKIP_BUILD_RPATH 1)
+endif()
# be able to see output from make on dashboards
-SET(CMAKE_VERBOSE_MAKEFILE 1)
+set(CMAKE_VERBOSE_MAKEFILE 1)
message("${CMAKE_MAKE_PROGRAM}")
set(CMAKE_PAREN TRUE)
-IF("${CMAKE_MAKE_PROGRAM}" MATCHES "wmake")
+if("${CMAKE_MAKE_PROGRAM}" MATCHES "wmake")
message("wmake does not support () in path")
set(CMAKE_PAREN FALSE)
elseif("${CMAKE_MAKE_PROGRAM}" MATCHES "make")
@@ -23,55 +23,55 @@ elseif("${CMAKE_MAKE_PROGRAM}" MATCHES "make")
endif()
endif()
-IF(CMAKE_PAREN)
- ADD_DEFINITIONS(-DCMAKE_PAREN=1)
- SUBDIRS("Executable Sources" "Some(x86) Sources" EXCLUDE_FROM_ALL "Some Examples")
-ELSE(CMAKE_PAREN)
- SUBDIRS("Executable Sources" EXCLUDE_FROM_ALL "Some Examples")
-ENDIF(CMAKE_PAREN)
+if(CMAKE_PAREN)
+ add_definitions(-DCMAKE_PAREN=1)
+ subdirs("Executable Sources" "Some(x86) Sources" EXCLUDE_FROM_ALL "Some Examples")
+else()
+ subdirs("Executable Sources" EXCLUDE_FROM_ALL "Some Examples")
+endif()
-WRITE_FILE(${SUBDIR_BINARY_DIR}/ShouldBeHere "This file should exist.")
+write_file(${SUBDIR_BINARY_DIR}/ShouldBeHere "This file should exist.")
#WATCOM WMAKE does not support + in the name of a file!
-IF(WATCOM)
- SET(PLUS_NAME_FILES
+if(WATCOM)
+ set(PLUS_NAME_FILES
"Another Subdir/pair_int.int.c"
vcl_algorithm_vcl_pair_double.foo.c)
-ELSE(WATCOM)
- SET(PLUS_NAME_FILES
+else()
+ set(PLUS_NAME_FILES
"Another Subdir/pair+int.int.c"
vcl_algorithm+vcl_pair+double.foo.c)
-ENDIF(WATCOM)
+endif()
-ADD_EXECUTABLE(TestFromSubdir
+add_executable(TestFromSubdir
"Another Subdir/testfromsubdir.c"
"Another Subdir/secondone"
${PLUS_NAME_FILES}
)
-AUX_SOURCE_DIRECTORY(ThirdSubDir SOURCES)
-IF(WATCOM)
- FOREACH(f ${SOURCES})
- IF("${f}" STREQUAL "ThirdSubDir/pair+int.int1.c")
- ELSE("${f}" STREQUAL "ThirdSubDir/pair+int.int1.c")
- SET(SOURCES2 ${f} ${SOURCES2})
- ENDIF("${f}" STREQUAL "ThirdSubDir/pair+int.int1.c")
- ENDFOREACH(f)
- SET(SOURCES ${SOURCES2})
- SET(SOURCES ${SOURCES}
+aux_source_directory(ThirdSubDir SOURCES)
+if(WATCOM)
+ foreach(f ${SOURCES})
+ if("${f}" STREQUAL "ThirdSubDir/pair+int.int1.c")
+ else()
+ set(SOURCES2 ${f} ${SOURCES2})
+ endif()
+ endforeach()
+ set(SOURCES ${SOURCES2})
+ set(SOURCES ${SOURCES}
vcl_algorithm_vcl_pair_double.foo.c)
-ELSE(WATCOM)
- FOREACH(f ${SOURCES})
- IF("${f}" STREQUAL "ThirdSubDir/pair_int.int1.c")
- ELSE("${f}" STREQUAL "ThirdSubDir/pair_int.int1.c")
- SET(SOURCES2 ${f} ${SOURCES2})
- ENDIF("${f}" STREQUAL "ThirdSubDir/pair_int.int1.c")
- ENDFOREACH(f)
- SET(SOURCES ${SOURCES2})
- SET(SOURCES ${SOURCES}
+else()
+ foreach(f ${SOURCES})
+ if("${f}" STREQUAL "ThirdSubDir/pair_int.int1.c")
+ else()
+ set(SOURCES2 ${f} ${SOURCES2})
+ endif()
+ endforeach()
+ set(SOURCES ${SOURCES2})
+ set(SOURCES ${SOURCES}
vcl_algorithm+vcl_pair+double.foo.c)
-ENDIF(WATCOM)
-ADD_EXECUTABLE(TestWithAuxSourceDir ${SOURCES})
-IF(CMAKE_PAREN)
+endif()
+add_executable(TestWithAuxSourceDir ${SOURCES})
+if(CMAKE_PAREN)
target_link_libraries(TestWithAuxSourceDir testOddPath)
-ENDIF(CMAKE_PAREN)
+endif()