summaryrefslogtreecommitdiff
path: root/Tests/SourceFileIncludeDirProperty/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/SourceFileIncludeDirProperty/CMakeLists.txt')
-rw-r--r--Tests/SourceFileIncludeDirProperty/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/Tests/SourceFileIncludeDirProperty/CMakeLists.txt b/Tests/SourceFileIncludeDirProperty/CMakeLists.txt
new file mode 100644
index 000000000..786d5b683
--- /dev/null
+++ b/Tests/SourceFileIncludeDirProperty/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 3.0)
+
+project(SourceFileIncludeDirProperty C)
+
+#
+# Check that source level include directory take
+# precedence over target one
+
+add_executable(SourceFileIncludeDirProperty main.c)
+
+set_property (TARGET SourceFileIncludeDirProperty
+ PROPERTY INCLUDE_DIRECTORIES "${CMAKE_CURRENT_SOURCE_DIR}/target")
+
+set_property (SOURCE main.c
+ PROPERTY INCLUDE_DIRECTORIES "${CMAKE_CURRENT_SOURCE_DIR}/source")