summaryrefslogtreecommitdiff
path: root/Tests/SetLang/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/SetLang/CMakeLists.txt')
-rw-r--r--Tests/SetLang/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/SetLang/CMakeLists.txt b/Tests/SetLang/CMakeLists.txt
new file mode 100644
index 000000000..ab6570c33
--- /dev/null
+++ b/Tests/SetLang/CMakeLists.txt
@@ -0,0 +1,10 @@
+# test forcing a source file language to c++ from c
+cmake_minimum_required (VERSION 2.6)
+project(SetLang)
+# force this to be verbose so I can debug a dashboard entry
+SET(CMAKE_VERBOSE_MAKEFILE 1)
+add_library(foo foo.c)
+add_executable(SetLang bar.c)
+set_source_files_properties(foo.c bar.c PROPERTIES LANGUAGE CXX)
+target_link_libraries(SetLang foo)
+set_target_properties(SetLang PROPERTIES LINKER_LANGUAGE CXX)