summaryrefslogtreecommitdiff
path: root/Tests/SameName/Exe1/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/SameName/Exe1/CMakeLists.txt')
-rw-r--r--Tests/SameName/Exe1/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/SameName/Exe1/CMakeLists.txt b/Tests/SameName/Exe1/CMakeLists.txt
new file mode 100644
index 000000000..3917a2f6b
--- /dev/null
+++ b/Tests/SameName/Exe1/CMakeLists.txt
@@ -0,0 +1,11 @@
+# a target with the same name as a target in a different dir
+ADD_EXECUTABLE(mytest_exe conly.c)
+SET_TARGET_PROPERTIES(mytest_exe PROPERTIES OUTPUT_NAME mytest)
+TARGET_LINK_LIBRARIES(mytest_exe mytest)
+
+# and two targets in the same dir with the same name
+ADD_LIBRARY(mytest2 ../Lib1/libc1.c)
+
+ADD_EXECUTABLE(mytest2_exe conly.c)
+SET_TARGET_PROPERTIES(mytest2_exe PROPERTIES OUTPUT_NAME mytest2)
+TARGET_LINK_LIBRARIES(mytest2_exe mytest2)