summaryrefslogtreecommitdiff
path: root/Tests/QtAutomoc/Adir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/QtAutomoc/Adir/CMakeLists.txt')
-rw-r--r--Tests/QtAutomoc/Adir/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/QtAutomoc/Adir/CMakeLists.txt b/Tests/QtAutomoc/Adir/CMakeLists.txt
new file mode 100644
index 000000000..171222319
--- /dev/null
+++ b/Tests/QtAutomoc/Adir/CMakeLists.txt
@@ -0,0 +1,8 @@
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_INCLUDE_CURRENT_DIR_IN_INTERFACE ON)
+
+add_library(libA SHARED libA.cpp)
+target_link_libraries(libA LINK_PUBLIC Qt4::QtCore)
+generate_export_header(libA)