summaryrefslogtreecommitdiff
path: root/Tests/Module/GenerateExportHeader/libstatictest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Module/GenerateExportHeader/libstatictest/CMakeLists.txt')
-rw-r--r--Tests/Module/GenerateExportHeader/libstatictest/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/Tests/Module/GenerateExportHeader/libstatictest/CMakeLists.txt b/Tests/Module/GenerateExportHeader/libstatictest/CMakeLists.txt
new file mode 100644
index 000000000..eb6bb874c
--- /dev/null
+++ b/Tests/Module/GenerateExportHeader/libstatictest/CMakeLists.txt
@@ -0,0 +1,18 @@
+
+macro(static_build_pass Source Message)
+ build_pass("libstatic.h" "libstatic" "libstatic" "${Source}" ${Message})
+endmacro()
+
+macro(static_build_fail Source Message)
+ build_fail("libstatic.h" "libstatic" "libstatic" "${Source}" ${Message})
+endmacro()
+
+static_build_pass("Libstatic l; return l.libstatic_exported();" "Failed to build exported.")
+
+# if (COMPILER_HAS_DEPRECATED)
+# static_build_fail("Libstatic l; return l.libstatic_deprecated();" "Built use of deprecated class method. This should not be possible.")
+# static_build_fail("libstatic_deprecated();" "Built use of deprecated function. This should not be possible.")
+# else()
+# static_build_pass("Libstatic l; return l.libstatic_deprecated();" "Built use of deprecated class method. This should not be possible.")
+# static_build_pass("libstatic_deprecated();" "Built use of deprecated function. This should not be possible.")
+# endif()