summaryrefslogtreecommitdiff
path: root/Tests/MFC/try_compile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/MFC/try_compile/CMakeLists.txt')
-rw-r--r--Tests/MFC/try_compile/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/Tests/MFC/try_compile/CMakeLists.txt b/Tests/MFC/try_compile/CMakeLists.txt
new file mode 100644
index 000000000..8e5d746f6
--- /dev/null
+++ b/Tests/MFC/try_compile/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 2.8)
+project(try_compile_mfc)
+
+set(files
+ stdafx.cpp
+ stdafx.h
+)
+
+set(CMAKE_MFC_FLAG "2")
+
+# VS generators add this automatically based on the CMAKE_MFC_FLAG value,
+# but generators matching "Make" require:
+add_definitions(-D_AFXDLL)
+
+add_executable(simplest_possible_mfc_exe WIN32 ${files})