summaryrefslogtreecommitdiff
path: root/Tests/LinkLine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/LinkLine/CMakeLists.txt')
-rw-r--r--Tests/LinkLine/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/LinkLine/CMakeLists.txt b/Tests/LinkLine/CMakeLists.txt
new file mode 100644
index 000000000..c8f0ecf63
--- /dev/null
+++ b/Tests/LinkLine/CMakeLists.txt
@@ -0,0 +1,12 @@
+PROJECT( LinkLine )
+
+# Makes sure that the library order as specified by the user are
+# unchanged by dependency analysis, etc. libOne and libTwo are
+# dependent on each other. The link line should be -lOne -lTwo -lOne.
+
+ADD_LIBRARY( One One.c )
+ADD_LIBRARY( Two Two.c )
+
+LINK_LIBRARIES( One Two )
+ADD_EXECUTABLE( LinkLine Exec.c )
+LINK_LIBRARIES( One )