summaryrefslogtreecommitdiff
path: root/Tests/FunctionTest/SubDirScope/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/FunctionTest/SubDirScope/CMakeLists.txt')
-rw-r--r--Tests/FunctionTest/SubDirScope/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/Tests/FunctionTest/SubDirScope/CMakeLists.txt b/Tests/FunctionTest/SubDirScope/CMakeLists.txt
new file mode 100644
index 000000000..4a53d2c0a
--- /dev/null
+++ b/Tests/FunctionTest/SubDirScope/CMakeLists.txt
@@ -0,0 +1,14 @@
+SET(SUBDIR_DEFINED 1 PARENT_SCOPE)
+SET(SUBDIR_UNDEFINED PARENT_SCOPE)
+
+# The above sets should not affect the current scope.
+IF(DEFINED SUBDIR_UNDEFINED)
+ PASS("SubdirScope Undefine Test" "(${SUBDIR_UNDEFINED})")
+ELSE(DEFINED SUBDIR_UNDEFINED)
+ FAILED("SubdirScope Undefine Test" "(${SUBDIR_UNDEFINED})")
+ENDIF(DEFINED SUBDIR_UNDEFINED)
+IF(DEFINED SUBDIR_DEFINED)
+ FAILED("SubdirScope Define Test" "(${SUBDIR_DEFINED})")
+ELSE(DEFINED SUBDIR_DEFINED)
+ PASS("SubdirScope Define Test" "(${SUBDIR_DEFINED})")
+ENDIF(DEFINED SUBDIR_DEFINED)