summaryrefslogtreecommitdiff
path: root/Tests/Fortran/Library/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Fortran/Library/CMakeLists.txt')
-rw-r--r--Tests/Fortran/Library/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/Tests/Fortran/Library/CMakeLists.txt b/Tests/Fortran/Library/CMakeLists.txt
index fe1368a07..17438cafb 100644
--- a/Tests/Fortran/Library/CMakeLists.txt
+++ b/Tests/Fortran/Library/CMakeLists.txt
@@ -1,11 +1,11 @@
-INCLUDE_DIRECTORIES(${Library_MODDIR})
-ADD_LIBRARY(subdir_mods a.f90 b.f90)
-ADD_EXECUTABLE(subdir_exe main.f90)
-TARGET_LINK_LIBRARIES(subdir_exe subdir_mods)
+include_directories(${Library_MODDIR})
+add_library(subdir_mods a.f90 b.f90)
+add_executable(subdir_exe main.f90)
+target_link_libraries(subdir_exe subdir_mods)
# Test module output directory if available.
-IF(CMAKE_Fortran_MODDIR_FLAG)
- SET_TARGET_PROPERTIES(subdir_mods PROPERTIES
+if(CMAKE_Fortran_MODDIR_FLAG)
+ set_target_properties(subdir_mods PROPERTIES
Fortran_MODULE_DIRECTORY modules
)
-ENDIF(CMAKE_Fortran_MODDIR_FLAG)
+endif()