summaryrefslogtreecommitdiff
path: root/Tests/Fortran/Library/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Fortran/Library/CMakeLists.txt')
-rw-r--r--Tests/Fortran/Library/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/Fortran/Library/CMakeLists.txt b/Tests/Fortran/Library/CMakeLists.txt
new file mode 100644
index 000000000..fe1368a07
--- /dev/null
+++ b/Tests/Fortran/Library/CMakeLists.txt
@@ -0,0 +1,11 @@
+INCLUDE_DIRECTORIES(${Library_MODDIR})
+ADD_LIBRARY(subdir_mods a.f90 b.f90)
+ADD_EXECUTABLE(subdir_exe main.f90)
+TARGET_LINK_LIBRARIES(subdir_exe subdir_mods)
+
+# Test module output directory if available.
+IF(CMAKE_Fortran_MODDIR_FLAG)
+ SET_TARGET_PROPERTIES(subdir_mods PROPERTIES
+ Fortran_MODULE_DIRECTORY modules
+ )
+ENDIF(CMAKE_Fortran_MODDIR_FLAG)