summaryrefslogtreecommitdiff
path: root/Tests/FindPython/ExactVersion/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/FindPython/ExactVersion/CMakeLists.txt')
-rw-r--r--Tests/FindPython/ExactVersion/CMakeLists.txt36
1 files changed, 18 insertions, 18 deletions
diff --git a/Tests/FindPython/ExactVersion/CMakeLists.txt b/Tests/FindPython/ExactVersion/CMakeLists.txt
index e09f73a9d..60abb2620 100644
--- a/Tests/FindPython/ExactVersion/CMakeLists.txt
+++ b/Tests/FindPython/ExactVersion/CMakeLists.txt
@@ -1,16 +1,16 @@
cmake_minimum_required(VERSION 3.1)
-project(TestExactVersion C)
+project(TestExactVersion LANGUAGES C)
find_package(Python${Python_MAJOR_VERSION} ${Python_REQUESTED_VERSION} COMPONENTS Interpreter Development)
-if (NOT Python${Python_MAJOR_VERSION}_FOUND)
- message (FATAL_ERROR "Fail to found Python ${Python_REQUESTED_VERSION}")
+if(NOT Python${Python_MAJOR_VERSION}_FOUND)
+ message (FATAL_ERROR "Failed to find Python ${Python_REQUESTED_VERSION}")
endif()
-if (NOT Python${Python_MAJOR_VERSION}_Interpreter_FOUND)
- message (FATAL_ERROR "Fail to found Python ${Python_REQUESTED_VERSION} Interpreter")
+if(NOT Python${Python_MAJOR_VERSION}_Interpreter_FOUND)
+ message (FATAL_ERROR "Failed to find Python ${Python_REQUESTED_VERSION} Interpreter")
endif()
-if (NOT Python${Python_MAJOR_VERSION}_Development_FOUND)
- message (FATAL_ERROR "Fail to found Python ${Python_REQUESTED_VERSION} Development")
+if(NOT Python${Python_MAJOR_VERSION}_Development_FOUND)
+ message (FATAL_ERROR "Failed to find Python ${Python_REQUESTED_VERSION} Development")
endif()
if(NOT TARGET Python${Python_MAJOR_VERSION}::Interpreter)
@@ -26,22 +26,22 @@ endif()
# reset artifacts and second search with exact version already founded
-unset (Python${Python_MAJOR_VERSION}_EXECUTABLE)
-unset (_Python${Python_MAJOR_VERSION}_EXECUTABLE CACHE)
+unset(Python${Python_MAJOR_VERSION}_EXECUTABLE)
+unset(_Python${Python_MAJOR_VERSION}_EXECUTABLE CACHE)
-unset (_Python${Python_MAJOR_VERSION}_LIBRARY_RELEASE CACHE)
-unset (_Python${Python_MAJOR_VERSION}_INCLUDE_DIR CACHE)
+unset(_Python${Python_MAJOR_VERSION}_LIBRARY_RELEASE CACHE)
+unset(_Python${Python_MAJOR_VERSION}_INCLUDE_DIR CACHE)
-set (Python_REQUESTED_VERSION ${Python${Python_MAJOR_VERSION}_VERSION})
+set(Python_REQUESTED_VERSION ${Python${Python_MAJOR_VERSION}_VERSION})
find_package(Python${Python_MAJOR_VERSION} ${Python_REQUESTED_VERSION} EXACT COMPONENTS Interpreter Development)
-if (NOT Python${Python_MAJOR_VERSION}_FOUND)
- message (FATAL_ERROR "Fail to found Python ${Python_REQUESTED_VERSION}")
+if(NOT Python${Python_MAJOR_VERSION}_FOUND)
+ message (FATAL_ERROR "Failed to find Python ${Python_REQUESTED_VERSION}")
endif()
-if (NOT Python${Python_MAJOR_VERSION}_Interpreter_FOUND)
- message (FATAL_ERROR "Fail to found Python ${Python_REQUESTED_VERSION} Interpreter")
+if(NOT Python${Python_MAJOR_VERSION}_Interpreter_FOUND)
+ message (FATAL_ERROR "Failed to find Python ${Python_REQUESTED_VERSION} Interpreter")
endif()
-if (NOT Python${Python_MAJOR_VERSION}_Development_FOUND)
- message (FATAL_ERROR "Fail to found Python ${Python_REQUESTED_VERSION} Development")
+if(NOT Python${Python_MAJOR_VERSION}_Development_FOUND)
+ message (FATAL_ERROR "Failed to find Python ${Python_REQUESTED_VERSION} Development")
endif()
if(NOT TARGET Python${Python_MAJOR_VERSION}::Interpreter)