summaryrefslogtreecommitdiff
path: root/Tests/FindBoost/TestPython/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/FindBoost/TestPython/CMakeLists.txt')
-rw-r--r--Tests/FindBoost/TestPython/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/Tests/FindBoost/TestPython/CMakeLists.txt b/Tests/FindBoost/TestPython/CMakeLists.txt
new file mode 100644
index 000000000..4d137ca0d
--- /dev/null
+++ b/Tests/FindBoost/TestPython/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 3.14)
+project(TestFindBoostPython CXX)
+include(CTest)
+
+find_package(Boost OPTIONAL_COMPONENTS python27 python34 python35 python36 python37)
+
+set(FAILTEST TRUE)
+foreach (v IN ITEMS 27 34 35 36 37)
+ if (Boost_PYTHON${v}_FOUND)
+ set(FAILTEST FALSE)
+ break()
+ endif ()
+endforeach ()
+
+if (FAILTEST)
+ message(FATAL_ERROR "No Boost Python module found")
+endif ()