summaryrefslogtreecommitdiff
path: root/Tests/Dependency/Four/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Dependency/Four/CMakeLists.txt')
-rw-r--r--Tests/Dependency/Four/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/Dependency/Four/CMakeLists.txt b/Tests/Dependency/Four/CMakeLists.txt
new file mode 100644
index 000000000..df0f1624e
--- /dev/null
+++ b/Tests/Dependency/Four/CMakeLists.txt
@@ -0,0 +1,6 @@
+INCLUDE_DIRECTORIES(${Dependency_BINARY_DIR}/Two)
+ADD_LIBRARY( Four FourSrc.c )
+TARGET_LINK_LIBRARIES( Four One Two NoDepA )
+
+# TwoCustom must build before Four.
+ADD_DEPENDENCIES(Four TwoCustom)