summaryrefslogtreecommitdiff
path: root/Tests/CustomCommandWorkingDirectory/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/CustomCommandWorkingDirectory/CMakeLists.txt')
-rw-r--r--Tests/CustomCommandWorkingDirectory/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/Tests/CustomCommandWorkingDirectory/CMakeLists.txt b/Tests/CustomCommandWorkingDirectory/CMakeLists.txt
index 36d32e4a0..f917cd7f3 100644
--- a/Tests/CustomCommandWorkingDirectory/CMakeLists.txt
+++ b/Tests/CustomCommandWorkingDirectory/CMakeLists.txt
@@ -1,28 +1,28 @@
cmake_minimum_required (VERSION 2.6)
-PROJECT(TestWorkingDir)
+project(TestWorkingDir)
-ADD_CUSTOM_COMMAND(
+add_custom_command(
OUTPUT "${TestWorkingDir_BINARY_DIR}/working.c"
COMMAND "${CMAKE_COMMAND}" -E copy ./working.c.in "${TestWorkingDir_BINARY_DIR}/working.c"
WORKING_DIRECTORY "${TestWorkingDir_SOURCE_DIR}"
COMMENT "custom command"
)
-SET_SOURCE_FILES_PROPERTIES(
+set_source_files_properties(
"${TestWorkingDir_BINARY_DIR}/customTarget.c"
"${TestWorkingDir_BINARY_DIR}/customTarget2.c"
PROPERTIES GENERATED 1)
-ADD_EXECUTABLE(working "${TestWorkingDir_BINARY_DIR}/working.c"
+add_executable(working "${TestWorkingDir_BINARY_DIR}/working.c"
"${TestWorkingDir_BINARY_DIR}/customTarget.c")
-ADD_CUSTOM_TARGET(
+add_custom_target(
Custom ALL
COMMAND "${CMAKE_COMMAND}" -E copy_if_different ./customTarget.c "${TestWorkingDir_BINARY_DIR}/customTarget.c"
WORKING_DIRECTORY "${TestWorkingDir_SOURCE_DIR}"
)
-ADD_DEPENDENCIES(working Custom)
+add_dependencies(working Custom)
file(MAKE_DIRECTORY ${TestWorkingDir_BINARY_DIR}/work)
add_custom_command(