summaryrefslogtreecommitdiff
path: root/Tests/CrossCompile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/CrossCompile/CMakeLists.txt')
-rw-r--r--Tests/CrossCompile/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/CrossCompile/CMakeLists.txt b/Tests/CrossCompile/CMakeLists.txt
new file mode 100644
index 000000000..96a57a051
--- /dev/null
+++ b/Tests/CrossCompile/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required (VERSION 2.6)
+PROJECT(CrossCompile)
+
+UNSET(run_result CACHE)
+
+#Simulate the cross compile condition
+SET(CMAKE_CROSSCOMPILING ON)
+
+ADD_EXECUTABLE(CrossCompile main.c)
+
+TRY_RUN(run_result compile_result
+ ${CrossCompile_BINARY_DIR}
+ ${CrossCompile_SOURCE_DIR}/main.c)