summaryrefslogtreecommitdiff
path: root/Tests/CompileCommandOutput/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/CompileCommandOutput/CMakeLists.txt')
-rw-r--r--Tests/CompileCommandOutput/CMakeLists.txt22
1 files changed, 11 insertions, 11 deletions
diff --git a/Tests/CompileCommandOutput/CMakeLists.txt b/Tests/CompileCommandOutput/CMakeLists.txt
index bd8e305c2..6f9468dca 100644
--- a/Tests/CompileCommandOutput/CMakeLists.txt
+++ b/Tests/CompileCommandOutput/CMakeLists.txt
@@ -2,15 +2,15 @@
cmake_minimum_required (VERSION 2.6)
project (CompileCommandOutput CXX)
-SET(CMAKE_EXPORT_COMPILE_COMMANDS ON)
+set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
set(CMAKE_DEBUG_POSTFIX "_test_debug_postfix")
-IF(MAKE_SUPPORTS_SPACES)
- SET(test1_srcs "file with spaces.cxx")
-ELSE()
- SET(test1_srcs "file_with_underscores.cxx")
-ENDIF()
-ADD_LIBRARY(test1 STATIC ${test1_srcs})
-ADD_LIBRARY(test2 SHARED "../CompileCommandOutput/relative.cxx")
-INCLUDE_DIRECTORIES(${CompileCommandOutput_SOURCE_DIR}/../../Source)
-ADD_EXECUTABLE(CompileCommandOutput compile_command_output.cxx)
-TARGET_LINK_LIBRARIES(CompileCommandOutput test1 test2)
+if(MAKE_SUPPORTS_SPACES)
+ set(test1_srcs "file with spaces.cxx")
+else()
+ set(test1_srcs "file_with_underscores.cxx")
+endif()
+add_library(test1 STATIC ${test1_srcs})
+add_library(test2 SHARED "../CompileCommandOutput/relative.cxx")
+include_directories(${CompileCommandOutput_SOURCE_DIR}/../../Source)
+add_executable(CompileCommandOutput compile_command_output.cxx)
+target_link_libraries(CompileCommandOutput test1 test2)