summaryrefslogtreecommitdiff
path: root/Tests/COnly/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/COnly/CMakeLists.txt')
-rw-r--r--Tests/COnly/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/Tests/COnly/CMakeLists.txt b/Tests/COnly/CMakeLists.txt
index 5ef0f1eea..b3cc43813 100644
--- a/Tests/COnly/CMakeLists.txt
+++ b/Tests/COnly/CMakeLists.txt
@@ -10,14 +10,14 @@ target_link_libraries(COnly testc1 testc2)
if(MSVC_VERSION)
set_target_properties(COnly PROPERTIES
LINK_FLAGS " /NODEFAULTLIB:\"libcdg.lib\" /NODEFAULTLIB:\"libcmtg.lib\" /NODEFAULTLIB:\"foomsvcrt.lib\" /NODEFAULTLIB:\"libbar.lib\" /NODEFAULTLIB:\"libfooba.lib\"")
-endif(MSVC_VERSION)
+endif()
string(ASCII 35 32 67 77 97 107 101 ASCII_STRING)
message(STATUS "String: ${ASCII_STRING}")
get_source_file_property(LANG conly.c LANGUAGE)
if("${LANG}" STREQUAL "C")
message("Language is C")
-else("${LANG}" STREQUAL "C")
+else()
message(FATAL_ERROR "Bad language for file conly.c")
-endif("${LANG}" STREQUAL "C")
+endif()
add_library(testCModule MODULE testCModule.c)