summaryrefslogtreecommitdiff
path: root/Tests/BundleTest/BundleSubDir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/BundleTest/BundleSubDir/CMakeLists.txt')
-rw-r--r--Tests/BundleTest/BundleSubDir/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/Tests/BundleTest/BundleSubDir/CMakeLists.txt b/Tests/BundleTest/BundleSubDir/CMakeLists.txt
index 322b2a7d2..1921ce095 100644
--- a/Tests/BundleTest/BundleSubDir/CMakeLists.txt
+++ b/Tests/BundleTest/BundleSubDir/CMakeLists.txt
@@ -1,36 +1,36 @@
-ADD_CUSTOM_COMMAND(
+add_custom_command(
OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/randomResourceFile.plist"
COMMAND /bin/cp
ARGS "${BundleTest_SOURCE_DIR}/randomResourceFile.plist.in"
"${CMAKE_CURRENT_BINARY_DIR}/randomResourceFile.plist")
-SET_SOURCE_FILES_PROPERTIES(
+set_source_files_properties(
"${CMAKE_CURRENT_BINARY_DIR}/randomResourceFile.plist"
PROPERTIES
MACOSX_PACKAGE_LOCATION Resources
)
-SET_SOURCE_FILES_PROPERTIES(
+set_source_files_properties(
"${BundleTest_SOURCE_DIR}/SomeRandomFile.txt"
"${BundleTest_SOURCE_DIR}/../../ChangeLog.txt"
PROPERTIES
MACOSX_PACKAGE_LOCATION MacOS
)
-ADD_EXECUTABLE(SecondBundle
+add_executable(SecondBundle
MACOSX_BUNDLE
"${BundleTest_SOURCE_DIR}/BundleTest.cxx"
"${BundleTest_SOURCE_DIR}/SomeRandomFile.txt"
"${BundleTest_SOURCE_DIR}/../../ChangeLog.txt"
"${CMAKE_CURRENT_BINARY_DIR}/randomResourceFile.plist"
)
-TARGET_LINK_LIBRARIES(SecondBundle BundleTestLib)
+target_link_libraries(SecondBundle BundleTestLib)
# Test bundle installation.
-INSTALL(TARGETS SecondBundle DESTINATION Applications)
+install(TARGETS SecondBundle DESTINATION Applications)
# Test whether bundles respect the output name. Since the library is
# installed into a location that uses this output name this will fail if the
# bundle does not respect the name. Also the executable will not be found by
# the test driver if this does not work.
-SET_TARGET_PROPERTIES(SecondBundle PROPERTIES OUTPUT_NAME SecondBundleExe)
+set_target_properties(SecondBundle PROPERTIES OUTPUT_NAME SecondBundleExe)