summaryrefslogtreecommitdiff
path: root/Tests/BundleGeneratorTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/BundleGeneratorTest/CMakeLists.txt')
-rw-r--r--Tests/BundleGeneratorTest/CMakeLists.txt34
1 files changed, 17 insertions, 17 deletions
diff --git a/Tests/BundleGeneratorTest/CMakeLists.txt b/Tests/BundleGeneratorTest/CMakeLists.txt
index e1fc2c1d4..037df09c1 100644
--- a/Tests/BundleGeneratorTest/CMakeLists.txt
+++ b/Tests/BundleGeneratorTest/CMakeLists.txt
@@ -1,23 +1,23 @@
-PROJECT(BundleGeneratorTest)
+project(BundleGeneratorTest)
-CMAKE_MINIMUM_REQUIRED(VERSION 2.7)
+cmake_minimum_required(VERSION 2.7)
# Build a shared library and install it in lib/
-ADD_LIBRARY(Library SHARED Library.cxx)
-INSTALL(TARGETS Library DESTINATION lib)
+add_library(Library SHARED Library.cxx)
+install(TARGETS Library DESTINATION lib)
# Build an executable and install it in bin/
-ADD_EXECUTABLE(Executable Executable.cxx)
-TARGET_LINK_LIBRARIES(Executable Library)
-INSTALL(TARGETS Executable DESTINATION bin)
+add_executable(Executable Executable.cxx)
+target_link_libraries(Executable Library)
+install(TARGETS Executable DESTINATION bin)
# Use the bundle-generator for packaging ...
-SET(CPACK_GENERATOR "Bundle")
-SET(CPACK_BUNDLE_ICON "${CMAKE_CURRENT_SOURCE_DIR}/BundleIcon.icns")
-SET(CPACK_BUNDLE_NAME "BundleGeneratorTest")
-SET(CPACK_BUNDLE_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/Info.plist")
-SET(CPACK_BUNDLE_STARTUP_COMMAND "${CMAKE_CURRENT_SOURCE_DIR}/StartupCommand")
-SET(CPACK_PACKAGE_DESCRIPTION "Project for testing OSX bundle generation")
+set(CPACK_GENERATOR "Bundle")
+set(CPACK_BUNDLE_ICON "${CMAKE_CURRENT_SOURCE_DIR}/BundleIcon.icns")
+set(CPACK_BUNDLE_NAME "BundleGeneratorTest")
+set(CPACK_BUNDLE_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/Info.plist")
+set(CPACK_BUNDLE_STARTUP_COMMAND "${CMAKE_CURRENT_SOURCE_DIR}/StartupCommand")
+set(CPACK_PACKAGE_DESCRIPTION "Project for testing OSX bundle generation")
# The custom volume icon is a copy of the normal Mac OSX volume icon, but
# on a white background. This is to differentiate it from the normal one
@@ -25,9 +25,9 @@ SET(CPACK_PACKAGE_DESCRIPTION "Project for testing OSX bundle generation")
# visual inspection of the mounted volume... This was added when fixing
# issue #7523...
#
-SET(CPACK_PACKAGE_ICON "${CMAKE_CURRENT_SOURCE_DIR}/CustomVolumeIcon.icns")
+set(CPACK_PACKAGE_ICON "${CMAKE_CURRENT_SOURCE_DIR}/CustomVolumeIcon.icns")
-SET(CPACK_PACKAGE_NAME "BundleGeneratorTest")
-SET(CPACK_PACKAGE_VERSION "0.1")
+set(CPACK_PACKAGE_NAME "BundleGeneratorTest")
+set(CPACK_PACKAGE_VERSION "0.1")
-INCLUDE(CPack)
+include(CPack)