summaryrefslogtreecommitdiff
path: root/Example/Demo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Example/Demo/CMakeLists.txt')
-rw-r--r--Example/Demo/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Example/Demo/CMakeLists.txt b/Example/Demo/CMakeLists.txt
new file mode 100644
index 000000000..477700fab
--- /dev/null
+++ b/Example/Demo/CMakeLists.txt
@@ -0,0 +1,12 @@
+# Make sure the compiler can find include files from our Hello library.
+include_directories (${HELLO_SOURCE_DIR}/Hello)
+
+# Make sure the linker can find the Hello library once it is built.
+link_directories (${HELLO_BINARY_DIR}/Hello)
+
+# Add executable called "helloDemo" that is built from the source files
+# "demo.cxx" and "demo_b.cxx". The extensions are automatically found.
+add_executable (helloDemo demo.cxx demo_b.cxx)
+
+# Link the executable to the Hello library.
+target_link_libraries (helloDemo Hello)