summaryrefslogtreecommitdiff
path: root/Example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Example/CMakeLists.txt')
-rw-r--r--Example/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Example/CMakeLists.txt b/Example/CMakeLists.txt
new file mode 100644
index 000000000..8ee7d721e
--- /dev/null
+++ b/Example/CMakeLists.txt
@@ -0,0 +1,10 @@
+# The name of our project is "HELLO". CMakeLists files in this project can
+# refer to the root source directory of the project as ${HELLO_SOURCE_DIR} and
+# to the root binary directory of the project as ${HELLO_BINARY_DIR}.
+project (HELLO)
+
+# Recurse into the "Hello" and "Demo" subdirectories. This does not actually
+# cause another cmake executable to run. The same process will walk through
+# the project's entire directory structure.
+add_subdirectory (Hello)
+add_subdirectory (Demo)