summaryrefslogtreecommitdiff
path: root/Docs/bash-completion/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Docs/bash-completion/CMakeLists.txt')
-rw-r--r--Docs/bash-completion/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Docs/bash-completion/CMakeLists.txt b/Docs/bash-completion/CMakeLists.txt
new file mode 100644
index 000000000..592b71e93
--- /dev/null
+++ b/Docs/bash-completion/CMakeLists.txt
@@ -0,0 +1,8 @@
+# Always install completion file in local dir
+# in order to be sure to always be able to install
+# in a local user directory rooted in a single directory.
+# packager should either patch that out or
+# add symlinks to the files in appropriate places
+# /etc/bash_completion.d/
+# DATADIR/completions (may be /usr/share/<package>/completions
+install(FILES cmake cpack ctest DESTINATION ${REL_CMAKE_DATA_DIR}/completions)