summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt704
1 files changed, 351 insertions, 353 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8522cad28..ea1c0339e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,71 +9,71 @@
# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
# See the License for more information.
#=============================================================================
-CMAKE_MINIMUM_REQUIRED(VERSION 2.8.2 FATAL_ERROR)
-SET(CMAKE_LEGACY_CYGWIN_WIN32 0) # Remove when CMake >= 2.8.4 is required
-PROJECT(CMake)
+cmake_minimum_required(VERSION 2.8.2 FATAL_ERROR)
+set(CMAKE_LEGACY_CYGWIN_WIN32 0) # Remove when CMake >= 2.8.4 is required
+project(CMake)
-IF(CMAKE_BOOTSTRAP)
+if(CMAKE_BOOTSTRAP)
# Running from bootstrap script. Set local variable and remove from cache.
- SET(CMAKE_BOOTSTRAP 1)
- UNSET(CMAKE_BOOTSTRAP CACHE)
-ENDIF()
+ set(CMAKE_BOOTSTRAP 1)
+ unset(CMAKE_BOOTSTRAP CACHE)
+endif()
-SET(CMake_BIN_DIR ${CMake_BINARY_DIR}/bin)
+set(CMake_BIN_DIR ${CMake_BINARY_DIR}/bin)
-IF("${CMake_SOURCE_DIR}" STREQUAL "${CMAKE_SOURCE_DIR}")
+if("${CMake_SOURCE_DIR}" STREQUAL "${CMAKE_SOURCE_DIR}")
# Disallow architecture-specific try_run. It may not run on the host.
- MACRO(TRY_RUN)
- IF(CMAKE_TRY_COMPILE_OSX_ARCHITECTURES)
- MESSAGE(FATAL_ERROR "TRY_RUN not allowed with CMAKE_TRY_COMPILE_OSX_ARCHITECTURES=[${CMAKE_TRY_COMPILE_OSX_ARCHITECTURES}]")
- ELSE()
+ macro(TRY_RUN)
+ if(CMAKE_TRY_COMPILE_OSX_ARCHITECTURES)
+ message(FATAL_ERROR "TRY_RUN not allowed with CMAKE_TRY_COMPILE_OSX_ARCHITECTURES=[${CMAKE_TRY_COMPILE_OSX_ARCHITECTURES}]")
+ else()
_TRY_RUN(${ARGV})
- ENDIF()
- ENDMACRO()
-ENDIF()
+ endif()
+ endmacro()
+endif()
#-----------------------------------------------------------------------
# a macro to deal with system libraries, implemented as a macro
# simply to improve readability of the main script
#-----------------------------------------------------------------------
-MACRO(CMAKE_HANDLE_SYSTEM_LIBRARIES)
+macro(CMAKE_HANDLE_SYSTEM_LIBRARIES)
# Options have dependencies.
- INCLUDE(CMakeDependentOption)
+ include(CMakeDependentOption)
# Optionally use system xmlrpc. We no longer build or use it by default.
- OPTION(CTEST_USE_XMLRPC "Enable xmlrpc submission method in CTest." OFF)
- MARK_AS_ADVANCED(CTEST_USE_XMLRPC)
+ option(CTEST_USE_XMLRPC "Enable xmlrpc submission method in CTest." OFF)
+ mark_as_advanced(CTEST_USE_XMLRPC)
# Allow the user to enable/disable all system utility library options by
# defining CMAKE_USE_SYSTEM_LIBRARIES or CMAKE_USE_SYSTEM_LIBRARY_${util}.
- SET(UTILITIES BZIP2 CURL EXPAT LIBARCHIVE ZLIB)
- FOREACH(util ${UTILITIES})
- IF(NOT DEFINED CMAKE_USE_SYSTEM_LIBRARY_${util}
+ set(UTILITIES BZIP2 CURL EXPAT LIBARCHIVE ZLIB)
+ foreach(util ${UTILITIES})
+ if(NOT DEFINED CMAKE_USE_SYSTEM_LIBRARY_${util}
AND DEFINED CMAKE_USE_SYSTEM_LIBRARIES)
- SET(CMAKE_USE_SYSTEM_LIBRARY_${util} "${CMAKE_USE_SYSTEM_LIBRARIES}")
- ENDIF()
- IF(DEFINED CMAKE_USE_SYSTEM_LIBRARY_${util})
- IF(CMAKE_USE_SYSTEM_LIBRARY_${util})
- SET(CMAKE_USE_SYSTEM_LIBRARY_${util} ON)
- ELSE()
- SET(CMAKE_USE_SYSTEM_LIBRARY_${util} OFF)
- ENDIF()
- IF(CMAKE_BOOTSTRAP)
- UNSET(CMAKE_USE_SYSTEM_LIBRARY_${util} CACHE)
- ENDIF()
- STRING(TOLOWER "${util}" lutil)
- SET(CMAKE_USE_SYSTEM_${util} "${CMAKE_USE_SYSTEM_LIBRARY_${util}}"
+ set(CMAKE_USE_SYSTEM_LIBRARY_${util} "${CMAKE_USE_SYSTEM_LIBRARIES}")
+ endif()
+ if(DEFINED CMAKE_USE_SYSTEM_LIBRARY_${util})
+ if(CMAKE_USE_SYSTEM_LIBRARY_${util})
+ set(CMAKE_USE_SYSTEM_LIBRARY_${util} ON)
+ else()
+ set(CMAKE_USE_SYSTEM_LIBRARY_${util} OFF)
+ endif()
+ if(CMAKE_BOOTSTRAP)
+ unset(CMAKE_USE_SYSTEM_LIBRARY_${util} CACHE)
+ endif()
+ string(TOLOWER "${util}" lutil)
+ set(CMAKE_USE_SYSTEM_${util} "${CMAKE_USE_SYSTEM_LIBRARY_${util}}"
CACHE BOOL "Use system-installed ${lutil}" FORCE)
- ELSE()
- SET(CMAKE_USE_SYSTEM_LIBRARY_${util} OFF)
- ENDIF()
- ENDFOREACH(util)
- IF(CMAKE_BOOTSTRAP)
- UNSET(CMAKE_USE_SYSTEM_LIBRARIES CACHE)
- ENDIF()
+ else()
+ set(CMAKE_USE_SYSTEM_LIBRARY_${util} OFF)
+ endif()
+ endforeach()
+ if(CMAKE_BOOTSTRAP)
+ unset(CMAKE_USE_SYSTEM_LIBRARIES CACHE)
+ endif()
# Optionally use system utility libraries.
- OPTION(CMAKE_USE_SYSTEM_LIBARCHIVE "Use system-installed libarchive" "${CMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE}")
+ option(CMAKE_USE_SYSTEM_LIBARCHIVE "Use system-installed libarchive" "${CMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE}")
CMAKE_DEPENDENT_OPTION(CMAKE_USE_SYSTEM_CURL "Use system-installed curl"
"${CMAKE_USE_SYSTEM_LIBRARY_CURL}" "NOT CTEST_USE_XMLRPC" ON)
CMAKE_DEPENDENT_OPTION(CMAKE_USE_SYSTEM_EXPAT "Use system-installed expat"
@@ -84,155 +84,154 @@ MACRO(CMAKE_HANDLE_SYSTEM_LIBRARIES)
"${CMAKE_USE_SYSTEM_LIBRARY_BZIP2}" "NOT CMAKE_USE_SYSTEM_LIBARCHIVE" ON)
# Mention to the user what system libraries are being used.
- FOREACH(util ${UTILITIES})
- IF(CMAKE_USE_SYSTEM_${util})
- MESSAGE(STATUS "Using system-installed ${util}")
- ENDIF(CMAKE_USE_SYSTEM_${util})
- ENDFOREACH(util)
+ foreach(util ${UTILITIES})
+ if(CMAKE_USE_SYSTEM_${util})
+ message(STATUS "Using system-installed ${util}")
+ endif()
+ endforeach()
# Inform utility library header wrappers whether to use system versions.
- CONFIGURE_FILE(${CMake_SOURCE_DIR}/Utilities/cmThirdParty.h.in
+ configure_file(${CMake_SOURCE_DIR}/Utilities/cmThirdParty.h.in
${CMake_BINARY_DIR}/Utilities/cmThirdParty.h
@ONLY)
-ENDMACRO(CMAKE_HANDLE_SYSTEM_LIBRARIES)
+endmacro()
-SET(CMAKE_BUILD_ON_VISUAL_STUDIO 0)
-IF(WIN32 AND NOT UNIX AND NOT BORLAND AND NOT MINGW )
- SET(CMAKE_BUILD_ON_VISUAL_STUDIO 1)
-ENDIF(WIN32 AND NOT UNIX AND NOT BORLAND AND NOT MINGW )
+set(CMAKE_BUILD_ON_VISUAL_STUDIO 0)
+if(WIN32 AND NOT UNIX AND NOT BORLAND AND NOT MINGW )
+ set(CMAKE_BUILD_ON_VISUAL_STUDIO 1)
+endif()
#-----------------------------------------------------------------------
# a macro to determine the generator and ctest executable to use
# for testing. Simply to improve readability of the main script.
#-----------------------------------------------------------------------
-MACRO(CMAKE_SETUP_TESTING)
- IF (NOT DART_ROOT)
- SET(MAKEPROGRAM ${CMAKE_MAKE_PROGRAM})
- ENDIF (NOT DART_ROOT)
-
- IF(BUILD_TESTING)
- SET(CMAKE_TEST_GENERATOR "" CACHE STRING
+macro(CMAKE_SETUP_TESTING)
+ if (NOT DART_ROOT)
+ set(MAKEPROGRAM ${CMAKE_MAKE_PROGRAM})
+ endif ()
+
+ if(BUILD_TESTING)
+ set(CMAKE_TEST_GENERATOR "" CACHE STRING
"Generator used when running tests")
- SET(CMAKE_TEST_MAKEPROGRAM "" CACHE FILEPATH
+ set(CMAKE_TEST_MAKEPROGRAM "" CACHE FILEPATH
"Generator used when running tests")
- IF(NOT CMAKE_TEST_GENERATOR)
- SET(CMAKE_TEST_GENERATOR "${CMAKE_GENERATOR}")
- SET(CMAKE_TEST_MAKEPROGRAM "${MAKEPROGRAM}")
- ELSE(NOT CMAKE_TEST_GENERATOR)
- SET(CMAKE_TEST_DIFFERENT_GENERATOR TRUE)
- ENDIF(NOT CMAKE_TEST_GENERATOR)
-
+ if(NOT CMAKE_TEST_GENERATOR)
+ set(CMAKE_TEST_GENERATOR "${CMAKE_GENERATOR}")
+ set(CMAKE_TEST_MAKEPROGRAM "${MAKEPROGRAM}")
+ else()
+ set(CMAKE_TEST_DIFFERENT_GENERATOR TRUE)
+ endif()
+
# Are we testing with the MSVC compiler?
- SET(CMAKE_TEST_MSVC 0)
- IF(MSVC AND NOT CMAKE_TEST_DIFFERENT_GENERATOR)
- SET(CMAKE_TEST_MSVC 1)
- ELSE(MSVC AND NOT CMAKE_TEST_DIFFERENT_GENERATOR)
- IF("${CMAKE_TEST_GENERATOR}" MATCHES "NMake" OR
+ set(CMAKE_TEST_MSVC 0)
+ if(MSVC AND NOT CMAKE_TEST_DIFFERENT_GENERATOR)
+ set(CMAKE_TEST_MSVC 1)
+ else()
+ if("${CMAKE_TEST_GENERATOR}" MATCHES "NMake" OR
"${CMAKE_TEST_GENERATOR}" MATCHES "Visual Studio")
- SET(CMAKE_TEST_MSVC 1)
- ENDIF("${CMAKE_TEST_GENERATOR}" MATCHES "NMake" OR
- "${CMAKE_TEST_GENERATOR}" MATCHES "Visual Studio")
- ENDIF(MSVC AND NOT CMAKE_TEST_DIFFERENT_GENERATOR)
-
- SET(CMAKE_TEST_SYSTEM_LIBRARIES 0)
- FOREACH(util CURL EXPAT XMLRPC ZLIB)
- IF(CMAKE_USE_SYSTEM_${util})
- SET(CMAKE_TEST_SYSTEM_LIBRARIES 1)
- ENDIF(CMAKE_USE_SYSTEM_${util})
- ENDFOREACH(util)
-
+ set(CMAKE_TEST_MSVC 1)
+ endif()
+ endif()
+
+ set(CMAKE_TEST_SYSTEM_LIBRARIES 0)
+ foreach(util CURL EXPAT XMLRPC ZLIB)
+ if(CMAKE_USE_SYSTEM_${util})
+ set(CMAKE_TEST_SYSTEM_LIBRARIES 1)
+ endif()
+ endforeach()
+
# This variable is set by cmake, however to
# test cmake we want to make sure that
# the ctest from this cmake is used for testing
# and not the ctest from the cmake building and testing
# cmake.
- SET(CMAKE_CTEST_COMMAND "${CMake_BIN_DIR}/ctest")
- SET(CMAKE_CMAKE_COMMAND "${CMake_BIN_DIR}/cmake")
- SET(CMAKE_CPACK_COMMAND "${CMake_BIN_DIR}/cpack")
- ENDIF(BUILD_TESTING)
+ set(CMAKE_CTEST_COMMAND "${CMake_BIN_DIR}/ctest")
+ set(CMAKE_CMAKE_COMMAND "${CMake_BIN_DIR}/cmake")
+ set(CMAKE_CPACK_COMMAND "${CMake_BIN_DIR}/cpack")
+ endif()
# configure some files for testing
- CONFIGURE_FILE("${CMAKE_CURRENT_SOURCE_DIR}/Templates/CTestScript.cmake.in"
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/Templates/CTestScript.cmake.in"
"${CMAKE_CURRENT_BINARY_DIR}/CTestScript.cmake"
@ONLY)
- CONFIGURE_FILE(${CMake_SOURCE_DIR}/Tests/.NoDartCoverage
+ configure_file(${CMake_SOURCE_DIR}/Tests/.NoDartCoverage
${CMake_BINARY_DIR}/Tests/.NoDartCoverage)
- CONFIGURE_FILE(${CMake_SOURCE_DIR}/Tests/.NoDartCoverage
+ configure_file(${CMake_SOURCE_DIR}/Tests/.NoDartCoverage
${CMake_BINARY_DIR}/Modules/.NoDartCoverage)
- CONFIGURE_FILE(${CMake_SOURCE_DIR}/CTestCustom.cmake.in
+ configure_file(${CMake_SOURCE_DIR}/CTestCustom.cmake.in
${CMake_BINARY_DIR}/CTestCustom.cmake @ONLY)
- CONFIGURE_FILE(${CMake_SOURCE_DIR}/CTestCustom.ctest.in
+ configure_file(${CMake_SOURCE_DIR}/CTestCustom.ctest.in
${CMake_BINARY_DIR}/CTestCustom.ctest @ONLY)
- IF(BUILD_TESTING AND DART_ROOT)
- CONFIGURE_FILE(${CMake_SOURCE_DIR}/CMakeLogo.gif
+ if(BUILD_TESTING AND DART_ROOT)
+ configure_file(${CMake_SOURCE_DIR}/CMakeLogo.gif
${CMake_BINARY_DIR}/Testing/HTML/TestingResults/Icons/Logo.gif COPYONLY)
- ENDIF(BUILD_TESTING AND DART_ROOT)
- MARK_AS_ADVANCED(DART_ROOT)
- MARK_AS_ADVANCED(CURL_TESTING)
-ENDMACRO(CMAKE_SETUP_TESTING)
+ endif()
+ mark_as_advanced(DART_ROOT)
+ mark_as_advanced(CURL_TESTING)
+endmacro()
# Provide a way for Visual Studio Express users to turn OFF the new FOLDER
# organization feature. Default to ON for non-Express users. Express users must
# explicitly turn off this option to build CMake in the Express IDE...
#
-OPTION(CMAKE_USE_FOLDERS "Enable folder grouping of projects in IDEs." ON)
-MARK_AS_ADVANCED(CMAKE_USE_FOLDERS)
+option(CMAKE_USE_FOLDERS "Enable folder grouping of projects in IDEs." ON)
+mark_as_advanced(CMAKE_USE_FOLDERS)
#-----------------------------------------------------------------------
# a macro that only sets the FOLDER target property if it's
# "appropriate"
#-----------------------------------------------------------------------
-MACRO(CMAKE_SET_TARGET_FOLDER tgt folder)
- IF(CMAKE_USE_FOLDERS)
- SET_PROPERTY(GLOBAL PROPERTY USE_FOLDERS ON)
+macro(CMAKE_SET_TARGET_FOLDER tgt folder)
+ if(CMAKE_USE_FOLDERS)
+ set_property(GLOBAL PROPERTY USE_FOLDERS ON)
# Really, I just want this to be an "if(TARGET ${tgt})" ...
# but I'm not sure that our min req'd., CMake 2.4.5 can handle
# that... so I'm just activating this for now, with a version
# compare, and only for MSVC builds.
- IF(MSVC)
- IF(NOT ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} LESS 2.8)
- SET_PROPERTY(TARGET "${tgt}" PROPERTY FOLDER "${folder}")
- ENDIF()
- ENDIF()
- ELSE()
- SET_PROPERTY(GLOBAL PROPERTY USE_FOLDERS OFF)
- ENDIF()
-ENDMACRO(CMAKE_SET_TARGET_FOLDER)
+ if(MSVC)
+ if(NOT ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} LESS 2.8)
+ set_property(TARGET "${tgt}" PROPERTY FOLDER "${folder}")
+ endif()
+ endif()
+ else()
+ set_property(GLOBAL PROPERTY USE_FOLDERS OFF)
+ endif()
+endmacro()
#-----------------------------------------------------------------------
# a macro to build the utilities used by CMake
# Simply to improve readability of the main script.
#-----------------------------------------------------------------------
-MACRO (CMAKE_BUILD_UTILITIES)
+macro (CMAKE_BUILD_UTILITIES)
#---------------------------------------------------------------------
# Create the KWIML library for CMake.
- SET(KWIML cmIML)
- SET(KWIML_HEADER_ROOT ${CMake_BINARY_DIR}/Utilities)
- ADD_SUBDIRECTORY(Utilities/KWIML)
+ set(KWIML cmIML)
+ set(KWIML_HEADER_ROOT ${CMake_BINARY_DIR}/Utilities)
+ add_subdirectory(Utilities/KWIML)
#---------------------------------------------------------------------
# Create the kwsys library for CMake.
- SET(KWSYS_NAMESPACE cmsys)
- SET(KWSYS_USE_SystemTools 1)
- SET(KWSYS_USE_Directory 1)
- SET(KWSYS_USE_RegularExpression 1)
- SET(KWSYS_USE_Base64 1)
- SET(KWSYS_USE_MD5 1)
- SET(KWSYS_USE_Process 1)
- SET(KWSYS_USE_CommandLineArguments 1)
- SET(KWSYS_HEADER_ROOT ${CMake_BINARY_DIR}/Source)
- SET(KWSYS_INSTALL_DOC_DIR "${CMake_DOC_DEST}")
- ADD_SUBDIRECTORY(Source/kwsys)
- SET(kwsys_folder "Utilities/KWSys")
+ set(KWSYS_NAMESPACE cmsys)
+ set(KWSYS_USE_SystemTools 1)
+ set(KWSYS_USE_Directory 1)
+ set(KWSYS_USE_RegularExpression 1)
+ set(KWSYS_USE_Base64 1)
+ set(KWSYS_USE_MD5 1)
+ set(KWSYS_USE_Process 1)
+ set(KWSYS_USE_CommandLineArguments 1)
+ set(KWSYS_HEADER_ROOT ${CMake_BINARY_DIR}/Source)
+ set(KWSYS_INSTALL_DOC_DIR "${CMake_DOC_DEST}")
+ add_subdirectory(Source/kwsys)
+ set(kwsys_folder "Utilities/KWSys")
CMAKE_SET_TARGET_FOLDER(${KWSYS_NAMESPACE} "${kwsys_folder}")
CMAKE_SET_TARGET_FOLDER(${KWSYS_NAMESPACE}_c "${kwsys_folder}")
CMAKE_SET_TARGET_FOLDER(${KWSYS_NAMESPACE}EncodeExecutable "${kwsys_folder}")
@@ -249,248 +248,248 @@ MACRO (CMAKE_BUILD_UTILITIES)
# Setup third-party libraries.
# Everything in the tree should be able to include files from the
# Utilities directory.
- INCLUDE_DIRECTORIES(
+ include_directories(
${CMake_BINARY_DIR}/Utilities
${CMake_SOURCE_DIR}/Utilities
)
-
+
# check for the use of system libraries versus builtin ones
# (a macro defined in this file)
CMAKE_HANDLE_SYSTEM_LIBRARIES()
-
+
#---------------------------------------------------------------------
# Build zlib library for Curl, CMake, and CTest.
- SET(CMAKE_ZLIB_HEADER "cm_zlib.h")
- IF(CMAKE_USE_SYSTEM_ZLIB)
- FIND_PACKAGE(ZLIB)
- IF(NOT ZLIB_FOUND)
- MESSAGE(FATAL_ERROR
+ set(CMAKE_ZLIB_HEADER "cm_zlib.h")
+ if(CMAKE_USE_SYSTEM_ZLIB)
+ find_package(ZLIB)
+ if(NOT ZLIB_FOUND)
+ message(FATAL_ERROR
"CMAKE_USE_SYSTEM_ZLIB is ON but a zlib is not found!")
- ENDIF(NOT ZLIB_FOUND)
- SET(CMAKE_ZLIB_INCLUDES ${ZLIB_INCLUDE_DIR})
- SET(CMAKE_ZLIB_LIBRARIES ${ZLIB_LIBRARIES})
- ELSE(CMAKE_USE_SYSTEM_ZLIB)
- SET(CMAKE_ZLIB_INCLUDES ${CMake_SOURCE_DIR}/Utilities)
- SET(CMAKE_ZLIB_LIBRARIES cmzlib)
- ADD_SUBDIRECTORY(Utilities/cmzlib)
+ endif()
+ set(CMAKE_ZLIB_INCLUDES ${ZLIB_INCLUDE_DIR})
+ set(CMAKE_ZLIB_LIBRARIES ${ZLIB_LIBRARIES})
+ else()
+ set(CMAKE_ZLIB_INCLUDES ${CMake_SOURCE_DIR}/Utilities)
+ set(CMAKE_ZLIB_LIBRARIES cmzlib)
+ add_subdirectory(Utilities/cmzlib)
CMAKE_SET_TARGET_FOLDER(cmzlib "Utilities/3rdParty")
- ENDIF(CMAKE_USE_SYSTEM_ZLIB)
-
+ endif()
+
#---------------------------------------------------------------------
# Build Curl library for CTest.
- IF(CMAKE_USE_SYSTEM_CURL)
- FIND_PACKAGE(CURL)
- IF(NOT CURL_FOUND)
- MESSAGE(FATAL_ERROR
+ if(CMAKE_USE_SYSTEM_CURL)
+ find_package(CURL)
+ if(NOT CURL_FOUND)
+ message(FATAL_ERROR
"CMAKE_USE_SYSTEM_CURL is ON but a curl is not found!")
- ENDIF(NOT CURL_FOUND)
- SET(CMAKE_CURL_INCLUDES ${CURL_INCLUDE_DIRS})
- SET(CMAKE_CURL_LIBRARIES ${CURL_LIBRARIES})
- ELSE(CMAKE_USE_SYSTEM_CURL)
- SET(CURL_SPECIAL_ZLIB_H ${CMAKE_ZLIB_HEADER})
- SET(CURL_SPECIAL_LIBZ_INCLUDES ${CMAKE_ZLIB_INCLUDES})
- SET(CURL_SPECIAL_LIBZ ${CMAKE_ZLIB_LIBRARIES})
- OPTION(CMAKE_BUILD_CURL_SHARED "Should curl be built shared" FALSE)
- IF(NOT CMAKE_BUILD_CURL_SHARED)
- ADD_DEFINITIONS(-DCURL_STATICLIB)
- ENDIF(NOT CMAKE_BUILD_CURL_SHARED)
- SET(CMAKE_CURL_INCLUDES)
- SET(CMAKE_CURL_LIBRARIES cmcurl)
- IF(CMAKE_TESTS_CDASH_SERVER)
- SET(CMAKE_CURL_TEST_URL "${CMAKE_TESTS_CDASH_SERVER}/user.php")
- ENDIF(CMAKE_TESTS_CDASH_SERVER)
- ADD_SUBDIRECTORY(Utilities/cmcurl)
+ endif()
+ set(CMAKE_CURL_INCLUDES ${CURL_INCLUDE_DIRS})
+ set(CMAKE_CURL_LIBRARIES ${CURL_LIBRARIES})
+ else()
+ set(CURL_SPECIAL_ZLIB_H ${CMAKE_ZLIB_HEADER})
+ set(CURL_SPECIAL_LIBZ_INCLUDES ${CMAKE_ZLIB_INCLUDES})
+ set(CURL_SPECIAL_LIBZ ${CMAKE_ZLIB_LIBRARIES})
+ option(CMAKE_BUILD_CURL_SHARED "Should curl be built shared" FALSE)
+ if(NOT CMAKE_BUILD_CURL_SHARED)
+ add_definitions(-DCURL_STATICLIB)
+ endif()
+ set(CMAKE_CURL_INCLUDES)
+ set(CMAKE_CURL_LIBRARIES cmcurl)
+ if(CMAKE_TESTS_CDASH_SERVER)
+ set(CMAKE_CURL_TEST_URL "${CMAKE_TESTS_CDASH_SERVER}/user.php")
+ endif()
+ add_subdirectory(Utilities/cmcurl)
CMAKE_SET_TARGET_FOLDER(cmcurl "Utilities/3rdParty")
CMAKE_SET_TARGET_FOLDER(LIBCURL "Utilities/3rdParty")
- ENDIF(CMAKE_USE_SYSTEM_CURL)
+ endif()
#---------------------------------------------------------------------
# Build Compress library for CTest.
- SET(CMAKE_COMPRESS_INCLUDES
+ set(CMAKE_COMPRESS_INCLUDES
"${CMAKE_CURRENT_BINARY_DIR}/Utilities/cmcompress")
- SET(CMAKE_COMPRESS_LIBRARIES "cmcompress")
- ADD_SUBDIRECTORY(Utilities/cmcompress)
+ set(CMAKE_COMPRESS_LIBRARIES "cmcompress")
+ add_subdirectory(Utilities/cmcompress)
CMAKE_SET_TARGET_FOLDER(cmcompress "Utilities/3rdParty")
- IF(CMAKE_USE_SYSTEM_BZIP2)
- FIND_PACKAGE(BZip2)
- ELSE()
- SET(BZIP2_INCLUDE_DIR
+ if(CMAKE_USE_SYSTEM_BZIP2)
+ find_package(BZip2)
+ else()
+ set(BZIP2_INCLUDE_DIR
"${CMAKE_CURRENT_SOURCE_DIR}/Utilities/cmbzip2")
- SET(BZIP2_LIBRARIES cmbzip2)
- ADD_SUBDIRECTORY(Utilities/cmbzip2)
+ set(BZIP2_LIBRARIES cmbzip2)
+ add_subdirectory(Utilities/cmbzip2)
CMAKE_SET_TARGET_FOLDER(cmbzip2 "Utilities/3rdParty")
- ENDIF()
+ endif()
#---------------------------------------------------------------------
# Build or use system libarchive for CMake and CTest.
- IF(CMAKE_USE_SYSTEM_LIBARCHIVE)
- IF(EXISTS ${CMAKE_ROOT}/Modules/FindLibArchive.cmake) # added in 2.8.3
- FIND_PACKAGE(LibArchive)
- ELSE()
- INCLUDE(${CMake_SOURCE_DIR}/Modules/FindLibArchive.cmake)
- ENDIF()
- IF(NOT LibArchive_FOUND)
- MESSAGE(FATAL_ERROR "CMAKE_USE_SYSTEM_LIBARCHIVE is ON but LibArchive is not found!")
- ENDIF()
- SET(CMAKE_TAR_INCLUDES ${LibArchive_INCLUDE_DIRS})
- SET(CMAKE_TAR_LIBRARIES ${LibArchive_LIBRARIES})
- ELSE(CMAKE_USE_SYSTEM_LIBARCHIVE)
- SET(ZLIB_INCLUDE_DIR ${CMAKE_ZLIB_INCLUDES})
- SET(ZLIB_LIBRARY ${CMAKE_ZLIB_LIBRARIES})
- ADD_DEFINITIONS(-DLIBARCHIVE_STATIC)
- SET(ENABLE_NETTLE OFF CACHE INTERNAL "Enable use of Nettle")
- SET(ENABLE_OPENSSL ${CMAKE_USE_OPENSSL} CACHE INTERNAL "Enable use of OpenSSL")
- SET(ENABLE_XATTR OFF CACHE INTERNAL "Enable extended attribute support")
- SET(ENABLE_ACL OFF CACHE INTERNAL "Enable ACL support")
- SET(ENABLE_ICONV OFF CACHE INTERNAL "Enable iconv support")
- ADD_SUBDIRECTORY(Utilities/cmlibarchive)
+ if(CMAKE_USE_SYSTEM_LIBARCHIVE)
+ if(EXISTS ${CMAKE_ROOT}/Modules/FindLibArchive.cmake) # added in 2.8.3
+ find_package(LibArchive)
+ else()
+ include(${CMake_SOURCE_DIR}/Modules/FindLibArchive.cmake)
+ endif()
+ if(NOT LibArchive_FOUND)
+ message(FATAL_ERROR "CMAKE_USE_SYSTEM_LIBARCHIVE is ON but LibArchive is not found!")
+ endif()
+ set(CMAKE_TAR_INCLUDES ${LibArchive_INCLUDE_DIRS})
+ set(CMAKE_TAR_LIBRARIES ${LibArchive_LIBRARIES})
+ else()
+ set(ZLIB_INCLUDE_DIR ${CMAKE_ZLIB_INCLUDES})
+ set(ZLIB_LIBRARY ${CMAKE_ZLIB_LIBRARIES})
+ add_definitions(-DLIBARCHIVE_STATIC)
+ set(ENABLE_NETTLE OFF CACHE INTERNAL "Enable use of Nettle")
+ set(ENABLE_OPENSSL ${CMAKE_USE_OPENSSL} CACHE INTERNAL "Enable use of OpenSSL")
+ set(ENABLE_XATTR OFF CACHE INTERNAL "Enable extended attribute support")
+ set(ENABLE_ACL OFF CACHE INTERNAL "Enable ACL support")
+ set(ENABLE_ICONV OFF CACHE INTERNAL "Enable iconv support")
+ add_subdirectory(Utilities/cmlibarchive)
CMAKE_SET_TARGET_FOLDER(cmlibarchive "Utilities/3rdParty")
- SET(CMAKE_TAR_LIBRARIES cmlibarchive ${BZIP2_LIBRARIES})
- ENDIF(CMAKE_USE_SYSTEM_LIBARCHIVE)
+ set(CMAKE_TAR_LIBRARIES cmlibarchive ${BZIP2_LIBRARIES})
+ endif()
#---------------------------------------------------------------------
# Build expat library for CMake and CTest.
- IF(CMAKE_USE_SYSTEM_EXPAT)
- FIND_PACKAGE(EXPAT)
- IF(NOT EXPAT_FOUND)
- MESSAGE(FATAL_ERROR
+ if(CMAKE_USE_SYSTEM_EXPAT)
+ find_package(EXPAT)
+ if(NOT EXPAT_FOUND)
+ message(FATAL_ERROR
"CMAKE_USE_SYSTEM_EXPAT is ON but a expat is not found!")
- ENDIF(NOT EXPAT_FOUND)
- SET(CMAKE_EXPAT_INCLUDES ${EXPAT_INCLUDE_DIRS})
- SET(CMAKE_EXPAT_LIBRARIES ${EXPAT_LIBRARIES})
- ELSE(CMAKE_USE_SYSTEM_EXPAT)
- SET(CMAKE_EXPAT_INCLUDES)
- SET(CMAKE_EXPAT_LIBRARIES cmexpat)
- ADD_SUBDIRECTORY(Utilities/cmexpat)
+ endif()
+ set(CMAKE_EXPAT_INCLUDES ${EXPAT_INCLUDE_DIRS})
+ set(CMAKE_EXPAT_LIBRARIES ${EXPAT_LIBRARIES})
+ else()
+ set(CMAKE_EXPAT_INCLUDES)
+ set(CMAKE_EXPAT_LIBRARIES cmexpat)
+ add_subdirectory(Utilities/cmexpat)
CMAKE_SET_TARGET_FOLDER(cmexpat "Utilities/3rdParty")
- ENDIF(CMAKE_USE_SYSTEM_EXPAT)
-
+ endif()
+
#---------------------------------------------------------------------
# Build XMLRPC library for CMake and CTest.
- IF(CTEST_USE_XMLRPC)
- FIND_PACKAGE(XMLRPC QUIET REQUIRED libwww-client)
- IF(NOT XMLRPC_FOUND)
- MESSAGE(FATAL_ERROR
+ if(CTEST_USE_XMLRPC)
+ find_package(XMLRPC QUIET REQUIRED libwww-client)
+ if(NOT XMLRPC_FOUND)
+ message(FATAL_ERROR
"CTEST_USE_XMLRPC is ON but xmlrpc is not found!")
- ENDIF(NOT XMLRPC_FOUND)
- SET(CMAKE_XMLRPC_INCLUDES ${XMLRPC_INCLUDE_DIRS})
- SET(CMAKE_XMLRPC_LIBRARIES ${XMLRPC_LIBRARIES})
- ENDIF(CTEST_USE_XMLRPC)
-
+ endif()
+ set(CMAKE_XMLRPC_INCLUDES ${XMLRPC_INCLUDE_DIRS})
+ set(CMAKE_XMLRPC_LIBRARIES ${XMLRPC_LIBRARIES})
+ endif()
+
#---------------------------------------------------------------------
# Use curses?
- IF (UNIX)
+ if (UNIX)
# there is a bug in the Syllable libraries which makes linking ccmake fail, Alex
- IF(NOT "${CMAKE_SYSTEM_NAME}" MATCHES syllable)
- SET(CURSES_NEED_NCURSES TRUE)
- FIND_PACKAGE(Curses QUIET)
- IF (CURSES_LIBRARY)
- OPTION(BUILD_CursesDialog "Build the CMake Curses Dialog ccmake" ON)
- ELSE (CURSES_LIBRARY)
- MESSAGE("Curses libraries were not found. Curses GUI for CMake will not be built.")
- SET(BUILD_CursesDialog 0)
- ENDIF (CURSES_LIBRARY)
- ELSE(NOT "${CMAKE_SYSTEM_NAME}" MATCHES syllable)
- SET(BUILD_CursesDialog 0)
- ENDIF(NOT "${CMAKE_SYSTEM_NAME}" MATCHES syllable)
- ELSE (UNIX)
- SET(BUILD_CursesDialog 0)
- ENDIF (UNIX)
- IF(BUILD_CursesDialog)
- ADD_SUBDIRECTORY(Source/CursesDialog/form)
- ENDIF(BUILD_CursesDialog)
-ENDMACRO (CMAKE_BUILD_UTILITIES)
+ if(NOT "${CMAKE_SYSTEM_NAME}" MATCHES syllable)
+ set(CURSES_NEED_NCURSES TRUE)
+ find_package(Curses QUIET)
+ if (CURSES_LIBRARY)
+ option(BUILD_CursesDialog "Build the CMake Curses Dialog ccmake" ON)
+ else ()
+ message("Curses libraries were not found. Curses GUI for CMake will not be built.")
+ set(BUILD_CursesDialog 0)
+ endif ()
+ else()
+ set(BUILD_CursesDialog 0)
+ endif()
+ else ()
+ set(BUILD_CursesDialog 0)
+ endif ()
+ if(BUILD_CursesDialog)
+ add_subdirectory(Source/CursesDialog/form)
+ endif()
+endmacro ()
#-----------------------------------------------------------------------
-IF(CMAKE_CXX_PLATFORM_ID MATCHES "OpenBSD")
- EXECUTE_PROCESS(COMMAND ${CMAKE_CXX_COMPILER}
+if(CMAKE_CXX_PLATFORM_ID MATCHES "OpenBSD")
+ execute_process(COMMAND ${CMAKE_CXX_COMPILER}
${CMAKE_CXX_COMPILER_ARG1} -dumpversion
OUTPUT_VARIABLE _GXX_VERSION
)
- STRING(REGEX REPLACE "([0-9])\\.([0-9])(\\.[0-9])?" "\\1\\2"
+ string(REGEX REPLACE "([0-9])\\.([0-9])(\\.[0-9])?" "\\1\\2"
_GXX_VERSION_SHORT ${_GXX_VERSION})
- IF(_GXX_VERSION_SHORT EQUAL 33)
- MESSAGE(FATAL_ERROR
+ if(_GXX_VERSION_SHORT EQUAL 33)
+ message(FATAL_ERROR
"GXX 3.3 on OpenBSD is known to cause CPack to Crash.\n"
"Please use GXX 4.2 or greater to build CMake on OpenBSD\n"
"${CMAKE_CXX_COMPILER} version is: ${_GXX_VERSION}")
- ENDIF()
-ENDIF()
+ endif()
+endif()
#-----------------------------------------------------------------------
# The main section of the CMakeLists file
#
#-----------------------------------------------------------------------
-INCLUDE(Source/CMakeVersion.cmake)
+include(Source/CMakeVersion.cmake)
# Releases define a small tweak level.
-IF("${CMake_VERSION_TWEAK}" VERSION_LESS 20000000)
- SET(CMake_VERSION_IS_RELEASE 1)
- SET(CMake_VERSION_SOURCE "")
-ELSE()
- SET(CMake_VERSION_IS_RELEASE 0)
- INCLUDE(${CMake_SOURCE_DIR}/Source/CMakeVersionSource.cmake)
-ENDIF()
+if("${CMake_VERSION_TWEAK}" VERSION_LESS 20000000)
+ set(CMake_VERSION_IS_RELEASE 1)
+ set(CMake_VERSION_SOURCE "")
+else()
+ set(CMake_VERSION_IS_RELEASE 0)
+ include(${CMake_SOURCE_DIR}/Source/CMakeVersionSource.cmake)
+endif()
# Compute the full version string.
-SET(CMake_VERSION ${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}.${CMake_VERSION_PATCH})
-IF(${CMake_VERSION_TWEAK} GREATER 0)
- SET(CMake_VERSION ${CMake_VERSION}.${CMake_VERSION_TWEAK})
-ENDIF()
-IF(CMake_VERSION_RC)
- SET(CMake_VERSION ${CMake_VERSION}-rc${CMake_VERSION_RC})
-ENDIF()
-IF(CMake_VERSION_SOURCE)
- SET(CMake_VERSION ${CMake_VERSION}-${CMake_VERSION_SOURCE})
-ENDIF()
+set(CMake_VERSION ${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}.${CMake_VERSION_PATCH})
+if(${CMake_VERSION_TWEAK} GREATER 0)
+ set(CMake_VERSION ${CMake_VERSION}.${CMake_VERSION_TWEAK})
+endif()
+if(CMake_VERSION_RC)
+ set(CMake_VERSION ${CMake_VERSION}-rc${CMake_VERSION_RC})
+endif()
+if(CMake_VERSION_SOURCE)
+ set(CMake_VERSION ${CMake_VERSION}-${CMake_VERSION_SOURCE})
+endif()
# Include the standard Dart testing module
-ENABLE_TESTING()
-INCLUDE (${CMAKE_ROOT}/Modules/Dart.cmake)
+enable_testing()
+include (${CMAKE_ROOT}/Modules/Dart.cmake)
# Set up test-time configuration.
-SET_DIRECTORY_PROPERTIES(PROPERTIES
+set_directory_properties(PROPERTIES
TEST_INCLUDE_FILE "${CMake_BINARY_DIR}/Tests/EnforceConfig.cmake")
# where to write the resulting executables and libraries
-SET(BUILD_SHARED_LIBS OFF)
-SET(EXECUTABLE_OUTPUT_PATH "" CACHE INTERNAL "No configurable exe dir.")
-SET(LIBRARY_OUTPUT_PATH "" CACHE INTERNAL
+set(BUILD_SHARED_LIBS OFF)
+set(EXECUTABLE_OUTPUT_PATH "" CACHE INTERNAL "No configurable exe dir.")
+set(LIBRARY_OUTPUT_PATH "" CACHE INTERNAL
"Where to put the libraries for CMake")
# The CMake executables usually do not need any rpath to run in the build or
# install tree.
-SET(CMAKE_SKIP_RPATH ON CACHE INTERNAL "CMake does not need RPATHs.")
+set(CMAKE_SKIP_RPATH ON CACHE INTERNAL "CMake does not need RPATHs.")
-SET(CMAKE_DATA_DIR "/share/cmake-${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}" CACHE STRING
+set(CMAKE_DATA_DIR "/share/cmake-${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}" CACHE STRING
"Install location for data (relative to prefix).")
-SET(CMAKE_DOC_DIR "/doc/cmake-${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}" CACHE STRING
+set(CMAKE_DOC_DIR "/doc/cmake-${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}" CACHE STRING
"Install location for documentation (relative to prefix).")
-SET(CMAKE_MAN_DIR "/man" CACHE STRING
+set(CMAKE_MAN_DIR "/man" CACHE STRING
"Install location for man pages (relative to prefix).")
-MARK_AS_ADVANCED(CMAKE_DATA_DIR CMAKE_DOC_DIR CMAKE_MAN_DIR)
-IF(CYGWIN AND EXISTS "${CMAKE_ROOT}/Modules/CPack.cmake")
+mark_as_advanced(CMAKE_DATA_DIR CMAKE_DOC_DIR CMAKE_MAN_DIR)
+if(CYGWIN AND EXISTS "${CMAKE_ROOT}/Modules/CPack.cmake")
# Force doc, data and man dirs to conform to cygwin layout.
- SET(CMAKE_DOC_DIR "/share/doc/cmake-${CMake_VERSION}")
- SET(CMAKE_DATA_DIR "/share/cmake-${CMake_VERSION}")
- SET(CMAKE_MAN_DIR "/share/man")
+ set(CMAKE_DOC_DIR "/share/doc/cmake-${CMake_VERSION}")
+ set(CMAKE_DATA_DIR "/share/cmake-${CMake_VERSION}")
+ set(CMAKE_MAN_DIR "/share/man")
# let the user know we just forced these values
- MESSAGE(STATUS "Setup for Cygwin packaging")
- MESSAGE(STATUS "Override cache CMAKE_DOC_DIR = ${CMAKE_DOC_DIR}")
- MESSAGE(STATUS "Override cache CMAKE_DATA_DIR = ${CMAKE_DATA_DIR}")
- MESSAGE(STATUS "Override cache CMAKE_MAN_DIR = ${CMAKE_MAN_DIR}")
-ENDIF()
-STRING(REGEX REPLACE "^/" "" CMake_DATA_DEST "${CMAKE_DATA_DIR}")
-STRING(REGEX REPLACE "^/" "" CMake_DOC_DEST "${CMAKE_DOC_DIR}")
-
-IF(BUILD_TESTING)
- INCLUDE(${CMake_SOURCE_DIR}/Tests/CMakeInstall.cmake)
-ENDIF()
+ message(STATUS "Setup for Cygwin packaging")
+ message(STATUS "Override cache CMAKE_DOC_DIR = ${CMAKE_DOC_DIR}")
+ message(STATUS "Override cache CMAKE_DATA_DIR = ${CMAKE_DATA_DIR}")
+ message(STATUS "Override cache CMAKE_MAN_DIR = ${CMAKE_MAN_DIR}")
+endif()
+string(REGEX REPLACE "^/" "" CMake_DATA_DEST "${CMAKE_DATA_DIR}")
+string(REGEX REPLACE "^/" "" CMake_DOC_DEST "${CMAKE_DOC_DIR}")
+
+if(BUILD_TESTING)
+ include(${CMake_SOURCE_DIR}/Tests/CMakeInstall.cmake)
+endif()
# include special compile flags for some compilers
-INCLUDE(CompileFlags.cmake)
+include(CompileFlags.cmake)
# no clue why we are testing for this here
-INCLUDE(CheckSymbolExists)
+include(CheckSymbolExists)
CHECK_SYMBOL_EXISTS(unsetenv "stdlib.h" HAVE_UNSETENV)
CHECK_SYMBOL_EXISTS(environ "stdlib.h" HAVE_ENVIRON_NOT_REQUIRE_PROTOTYPE)
@@ -507,91 +506,90 @@ CHECK_SYMBOL_EXISTS(environ "stdlib.h" HAVE_ENVIRON_NOT_REQUIRE_PROTOTYPE)
# to a cdash4simpletest database. In these cases, the CDash dashboards
# should be run first.
#
-IF("x${CMAKE_TESTS_CDASH_SERVER}" STREQUAL "x")
- SET(CMAKE_TESTS_CDASH_SERVER "http://www.cdash.org/CDash")
-ENDIF("x${CMAKE_TESTS_CDASH_SERVER}" STREQUAL "x")
+if("x${CMAKE_TESTS_CDASH_SERVER}" STREQUAL "x")
+ set(CMAKE_TESTS_CDASH_SERVER "http://www.cdash.org/CDash")
+endif()
-# build the utilities (a macro defined in this file)
+# build the utilities (a macro defined in this file)
CMAKE_BUILD_UTILITIES()
# On NetBSD ncurses is required, since curses doesn't have the wsyncup()
# function. ncurses is installed via pkgsrc, so the library is in /usr/pkg/lib,
-# which isn't in the default linker search path. So without RPATH ccmake
+# which isn't in the default linker search path. So without RPATH ccmake
# doesn't run and the build doesn't succeed since ccmake is executed for
# generating the documentation.
-IF(BUILD_CursesDialog)
- GET_FILENAME_COMPONENT(_CURSES_DIR "${CURSES_LIBRARY}" PATH)
- SET(CURSES_NEED_RPATH FALSE)
- IF(NOT "${_CURSES_DIR}" STREQUAL "/lib" AND NOT "${_CURSES_DIR}" STREQUAL "/usr/lib" AND NOT "${_CURSES_DIR}" STREQUAL "/lib64" AND NOT "${_CURSES_DIR}" STREQUAL "/usr/lib64")
- SET(CURSES_NEED_RPATH TRUE)
- ENDIF(NOT "${_CURSES_DIR}" STREQUAL "/lib" AND NOT "${_CURSES_DIR}" STREQUAL "/usr/lib" AND NOT "${_CURSES_DIR}" STREQUAL "/lib64" AND NOT "${_CURSES_DIR}" STREQUAL "/usr/lib64")
-ENDIF(BUILD_CursesDialog)
-
-IF(BUILD_QtDialog)
- IF(APPLE)
- SET(CMAKE_BUNDLE_NAME
+if(BUILD_CursesDialog)
+ get_filename_component(_CURSES_DIR "${CURSES_LIBRARY}" PATH)
+ set(CURSES_NEED_RPATH FALSE)
+ if(NOT "${_CURSES_DIR}" STREQUAL "/lib" AND NOT "${_CURSES_DIR}" STREQUAL "/usr/lib" AND NOT "${_CURSES_DIR}" STREQUAL "/lib64" AND NOT "${_CURSES_DIR}" STREQUAL "/usr/lib64")
+ set(CURSES_NEED_RPATH TRUE)
+ endif()
+endif()
+
+if(BUILD_QtDialog)
+ if(APPLE)
+ set(CMAKE_BUNDLE_NAME
"CMake ${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}-${CMake_VERSION_PATCH}")
- SET(CMAKE_BUNDLE_LOCATION "${CMAKE_INSTALL_PREFIX}")
+ set(CMAKE_BUNDLE_LOCATION "${CMAKE_INSTALL_PREFIX}")
# make sure CMAKE_INSTALL_PREFIX ends in /
- STRING(LENGTH "${CMAKE_INSTALL_PREFIX}" LEN)
- MATH(EXPR LEN "${LEN} -1" )
- STRING(SUBSTRING "${CMAKE_INSTALL_PREFIX}" ${LEN} 1 ENDCH)
- IF(NOT "${ENDCH}" STREQUAL "/")
- SET(CMAKE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}/")
- ENDIF(NOT "${ENDCH}" STREQUAL "/")
- SET(CMAKE_INSTALL_PREFIX
+ string(LENGTH "${CMAKE_INSTALL_PREFIX}" LEN)
+ math(EXPR LEN "${LEN} -1" )
+ string(SUBSTRING "${CMAKE_INSTALL_PREFIX}" ${LEN} 1 ENDCH)
+ if(NOT "${ENDCH}" STREQUAL "/")
+ set(CMAKE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}/")
+ endif()
+ set(CMAKE_INSTALL_PREFIX
"${CMAKE_INSTALL_PREFIX}${CMAKE_BUNDLE_NAME}.app/Contents")
- ENDIF(APPLE)
-
- SET(QT_NEED_RPATH FALSE)
- IF(NOT "${QT_LIBRARY_DIR}" STREQUAL "/lib" AND NOT "${QT_LIBRARY_DIR}" STREQUAL "/usr/lib" AND NOT "${QT_LIBRARY_DIR}" STREQUAL "/lib64" AND NOT "${QT_LIBRARY_DIR}" STREQUAL "/usr/lib64")
- SET(QT_NEED_RPATH TRUE)
- ENDIF(NOT "${QT_LIBRARY_DIR}" STREQUAL "/lib" AND NOT "${QT_LIBRARY_DIR}" STREQUAL "/usr/lib" AND NOT "${QT_LIBRARY_DIR}" STREQUAL "/lib64" AND NOT "${QT_LIBRARY_DIR}" STREQUAL "/usr/lib64")
-ENDIF(BUILD_QtDialog)
+ endif()
+
+ set(QT_NEED_RPATH FALSE)
+ if(NOT "${QT_LIBRARY_DIR}" STREQUAL "/lib" AND NOT "${QT_LIBRARY_DIR}" STREQUAL "/usr/lib" AND NOT "${QT_LIBRARY_DIR}" STREQUAL "/lib64" AND NOT "${QT_LIBRARY_DIR}" STREQUAL "/usr/lib64")
+ set(QT_NEED_RPATH TRUE)
+ endif()
+endif()
# The same might be true on other systems for other libraries.
-# Then only enable RPATH if we have are building at least with cmake 2.4,
+# Then only enable RPATH if we have are building at least with cmake 2.4,
# since this one has much better RPATH features than cmake 2.2.
# The executables are then built with the RPATH for the libraries outside
# the build tree, which is both the build and the install RPATH.
-IF (UNIX)
- IF( CMAKE_USE_SYSTEM_CURL OR CMAKE_USE_SYSTEM_ZLIB
+if (UNIX)
+ if( CMAKE_USE_SYSTEM_CURL OR CMAKE_USE_SYSTEM_ZLIB
OR CMAKE_USE_SYSTEM_EXPAT OR CTEST_USE_XMLRPC OR CURSES_NEED_RPATH OR QT_NEED_RPATH)
- SET(CMAKE_SKIP_RPATH OFF CACHE INTERNAL "CMake built with RPATH.")
- SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
- SET(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
- ENDIF(CMAKE_USE_SYSTEM_CURL OR CMAKE_USE_SYSTEM_ZLIB
- OR CMAKE_USE_SYSTEM_EXPAT OR CTEST_USE_XMLRPC OR CURSES_NEED_RPATH OR QT_NEED_RPATH)
-ENDIF (UNIX)
+ set(CMAKE_SKIP_RPATH OFF CACHE INTERNAL "CMake built with RPATH.")
+ set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+ set(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
+ endif()
+endif ()
# add the uninstall support
-CONFIGURE_FILE(
+configure_file(
"${CMAKE_CURRENT_SOURCE_DIR}/cmake_uninstall.cmake.in"
"${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
@ONLY)
-ADD_CUSTOM_TARGET(uninstall
+add_custom_target(uninstall
"${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
-INCLUDE (CMakeCPack.cmake)
+include (CMakeCPack.cmake)
# setup some Testing support (a macro defined in this file)
CMAKE_SETUP_TESTING()
-CONFIGURE_FILE(
+configure_file(
"${CMAKE_CURRENT_SOURCE_DIR}/DartLocal.conf.in"
"${CMAKE_CURRENT_BINARY_DIR}/DartLocal.conf"
COPYONLY)
-OPTION(CMAKE_STRICT
+option(CMAKE_STRICT
"Perform strict testing to record property and variable access. Can be used to report any undefined properties or variables" OFF)
-MARK_AS_ADVANCED(CMAKE_STRICT)
+mark_as_advanced(CMAKE_STRICT)
# build the remaining subdirectories
-ADD_SUBDIRECTORY(Source)
-ADD_SUBDIRECTORY(Utilities)
-ADD_SUBDIRECTORY(Tests)
+add_subdirectory(Source)
+add_subdirectory(Utilities)
+add_subdirectory(Tests)
if(BUILD_TESTING)
CMAKE_SET_TARGET_FOLDER(CMakeLibTests "Tests")
@@ -600,14 +598,14 @@ CMAKE_SET_TARGET_FOLDER(cmw9xcom "Utilities/Win9xCompat")
CMAKE_SET_TARGET_FOLDER(documentation "Documentation")
# add a test
-ADD_TEST(SystemInformationNew "${CMAKE_CMAKE_COMMAND}"
+add_test(SystemInformationNew "${CMAKE_CMAKE_COMMAND}"
--system-information -G "${CMAKE_TEST_GENERATOR}" )
# Install license file as it requires.
-INSTALL(FILES Copyright.txt DESTINATION ${CMake_DOC_DEST})
+install(FILES Copyright.txt DESTINATION ${CMake_DOC_DEST})
# Install script directories.
-INSTALL(
+install(
DIRECTORY Modules Templates
DESTINATION "${CMake_DATA_DEST}"
FILE_PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
@@ -620,7 +618,7 @@ INSTALL(
)
# process docs related install
-ADD_SUBDIRECTORY(Docs)
+add_subdirectory(Docs)
#-----------------------------------------------------------------------
# End of the main section of the CMakeLists file
@@ -631,4 +629,4 @@ ADD_SUBDIRECTORY(Docs)
# to compute the location of the "cmake" executable. We set it here
# so that those CMake versions can find it. We wait until after all
# the add_subdirectory() calls to avoid affecting the subdirectories.
-SET(EXECUTABLE_OUTPUT_PATH ${CMake_BIN_DIR})
+set(EXECUTABLE_OUTPUT_PATH ${CMake_BIN_DIR})