summaryrefslogtreecommitdiff
path: root/Utilities/Doxygen/CMakeLists.txt
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-10-30 15:39:57 -0700
committerAnas Nashif <anas.nashif@intel.com>2012-10-30 15:39:57 -0700
commit035c7fabc3b82cbc9a346c11abe2e9462b4c0379 (patch)
tree7e40f5a790eae329a8c5d3e59f046451767956ff /Utilities/Doxygen/CMakeLists.txt
downloadcmake-035c7fabc3b82cbc9a346c11abe2e9462b4c0379.tar.gz
cmake-035c7fabc3b82cbc9a346c11abe2e9462b4c0379.tar.bz2
cmake-035c7fabc3b82cbc9a346c11abe2e9462b4c0379.zip
Imported Upstream version 2.8.9upstream/2.8.9
Diffstat (limited to 'Utilities/Doxygen/CMakeLists.txt')
-rw-r--r--Utilities/Doxygen/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/Utilities/Doxygen/CMakeLists.txt b/Utilities/Doxygen/CMakeLists.txt
new file mode 100644
index 000000000..2430391fd
--- /dev/null
+++ b/Utilities/Doxygen/CMakeLists.txt
@@ -0,0 +1,39 @@
+#=============================================================================
+# CMake - Cross Platform Makefile Generator
+# Copyright 2000-2009 Kitware, Inc., Insight Software Consortium
+#
+# Distributed under the OSI-approved BSD License (the "License");
+# see accompanying file Copyright.txt for details.
+#
+# This software is distributed WITHOUT ANY WARRANTY; without even the
+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+# See the License for more information.
+#=============================================================================
+
+#
+# Build the documentation
+#
+INCLUDE (${CMAKE_ROOT}/Modules/Documentation.cmake OPTIONAL)
+
+IF (BUILD_DOCUMENTATION)
+
+ #
+ # Configure the script and the doxyfile, then add target
+ #
+ IF(NOT DOT_PATH)
+ GET_FILENAME_COMPONENT(DOT_PATH ${DOT} PATH)
+ ENDIF(NOT DOT_PATH)
+
+ CONFIGURE_FILE(
+ ${CMake_SOURCE_DIR}/Utilities/Doxygen/doxyfile.in
+ ${CMake_BINARY_DIR}/Utilities/Doxygen/doxyfile)
+
+ CONFIGURE_FILE(
+ ${CMake_SOURCE_DIR}/Utilities/Doxygen/doc_makeall.sh.in
+ ${CMake_BINARY_DIR}/Utilities/Doxygen/doc_makeall.sh)
+
+ ADD_CUSTOM_TARGET(DoxygenDoc
+ ${BASH}
+ ${CMake_BINARY_DIR}/Utilities/Doxygen/doc_makeall.sh)
+
+ENDIF (BUILD_DOCUMENTATION)